Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Cutter's Avatar
    Join Date
    May 2005
    Location
    Vancouver, B.C.
    Posts
    175
    +1
    3

    Engine builders have a question for ya.

    What would make this happen after only a few hours of riding? I've done so many motors & have never seen such quick damage.

    Little history on this motor. It let go a before then the dealer took it to a machine shop of the customers choosing. They put it together, lasted an hour & had similar damage. Dealer bitched then they kinda of warrantied the job. Re-sleeved the block & gave new pistons but would not assemble it. I put it all together then that happens. When it was running it did sound very loose in the top end as well. Almost as though there wasn't enough oil pressure getting to the rockers. No light or code ever came on though.

    Any input would be great.

    Thanks!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20190618_220852.jpg 
Views:	127 
Size:	96.7 KB 
ID:	450043   Click image for larger version. 

Name:	20190618_220829.jpg 
Views:	114 
Size:	95.3 KB 
ID:	450044   Click image for larger version. 

Name:	20190618_221001.jpg 
Views:	119 
Size:	63.4 KB 
ID:	450045   Click image for larger version. 

Name:	20190618_221010.jpg 
Views:	106 
Size:	62.3 KB 
ID:	450046   Click image for larger version. 

Name:	20190618_221014.jpg 
Views:	97 
Size:	58.2 KB 
ID:	450047  

  2. #2
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,705
    +1
    772
    Stock motor? Tune? What was the piston to bore clearance?

    The clearance was too small for the amount of expansion the pistons experienced.

    It got very lean and hot and/or the piston to wall clearance was way too small.

  3. #3
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,636
    +1
    193
    How did the oil pumps look? What year block and head set up?

    How much boost was it running, and what size injectors?

  4. #4
    My gut feeling is the machine work wasnt right. Did you check bore clearance? How did the plugs and piston faces look? Any chance it has cooling system issues?

  5. #5
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,936
    +1
    203
    Not stock for sure , carillo rods and not oem pistons .

  6. #6

    Join Date
    May 2012
    Location
    California
    Posts
    1,901
    +1
    177
    Quote Originally Posted by DR2006RXP View Post
    Not stock for sure , carillo rods and not oem pistons .
    yep, I bet not enough wall clearance, probably using stock specs on high boost application


  7. #7
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,532
    +1
    160
    Not sure if it's the camera angle in the cylinder pics or not, but pic 1 and 2 seem to have the oil squirter partly or totally blocked, #3 is clear.
    Not that it caused the failure, just an observation

  8. #8

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    973
    +1
    57
    I had the same thing happen...weisco..pistons...not enough clearance....

  9. #9
    http://greenhulk.net/forums/showthre...=277606&page=4

    Check that link - my thread on my GP1800R, identical damage.

  10. #10
    Mighty Mouse's Avatar
    Join Date
    Feb 2011
    Location
    Mississippi
    Posts
    959
    +1
    28
    Did the "machine shop" put it back together or the dealer?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Here's a good one for you engine builders
    By MWHC in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-05-2018, 09:53 PM
  2. Engine Builders and Machine Services
    By rcrisafulli in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 09-05-2017, 08:28 PM
  3. Questions for you engine builders
    By ecu1984 in forum 4-Tec Performance
    Replies: 13
    Last Post: 02-26-2017, 10:19 PM
  4. Engine builders, who is trustworthy?
    By awd98tsi in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-21-2009, 07:51 PM
  5. ? for top GPR engine builders
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-13-2006, 02:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •