Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88

    Strange. Cavitation

    Anyone ever experience this? Strangest thing ever, was riding today in ocean and started cavitating as if I had sea weed or something wedged in grate. I jumped out to check and nothing. I figured maybe it blew out so I continued riding. However it didnít get better. So I assumed something was wedged in there or maybe my prop broke. I decided to go in for the day and take my pump apart to check. I was sure something was bad but everything was perfect! The only thing I saw that was slightly off was the solas collar was not seated on the prop but I highly doubt that would cause what I experienced.

    Something to note. After long idle zones, ski will bog/hesitate for a second.

    Only mod I have done since this started is the aqua sport o2 sensor adapter.

  2. +1 by:


  3. #2
    Super Jim's Avatar
    Join Date
    Feb 2007
    Location
    Lake Wylie, SC
    Posts
    309
    +1
    32
    My first guess was sea weed. second guess was the impeller nose cone came loose and moved forward. That will certainly do it. The aluminum nose cones are notorious for that and it does cause cavitation. Hard to believe how much it causes to be so small. I think that is the main reason people just leave them out.

  4. +1 by:


  5. #3
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88
    That’s what it was. The cone was separated from the impeller and was probably sliding up and down the shaft

    Quote Originally Posted by Super Jim View Post
    My first guess was sea weed. second guess was the impeller nose cone came loose and moved forward. That will certainly do it. The aluminum nose cones are notorious for that and it does cause cavitation. Hard to believe how much it causes to be so small. I think that is the main reason people just leave them out.

  6. +1 by:


  7. #4

    Join Date
    Aug 2011
    Location
    Middle River, MD
    Posts
    529
    +1
    60
    Simple and helpful thread right here. Im sure this has happened to others.

    Glad you figured it out Dan


  8. #5
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88
    Me too! What a strange thing. Most would have been scratching their head for hours trying to figure it out. Because there was nothing obviously wrong... I would just keep that cap off from now on.

    As far as the bogging after long idle periods, what could that be? Water box getting to full?

  9. #6
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88
    Thank you for your input Jim!
    Quote Originally Posted by Super Jim View Post
    My first guess was sea weed. second guess was the impeller nose cone came loose and moved forward. That will certainly do it. The aluminum nose cones are notorious for that and it does cause cavitation. Hard to believe how much it causes to be so small. I think that is the main reason people just leave them out.

  10. #7
    Gixxxerboy's Avatar
    Join Date
    Jun 2012
    Location
    Metairie, La
    Posts
    104
    +1
    15
    After reading this, I crawled underneath to get a look at my nose cone because I have tons of cavitation from a dead. My nose cone does not look completely seated and flush up against the impeller. There is a very small gap between the two but it does seem to be locked on and is not moving. Wonder if I am experiencing cavitation from this as well?

  11. #8
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88
    Mine was like that also. That is probably where it says adult. I am sure that when you are under a load that it is spinning up and down the shaft

  12. #9
    Super Jim's Avatar
    Join Date
    Feb 2007
    Location
    Lake Wylie, SC
    Posts
    309
    +1
    32
    Quote Originally Posted by DanSVHO View Post
    Me too!.

    As far as the bogging after long idle periods, what could that be? Water box getting to full?
    How many hours? Stock tune? What mods?

  13. #10
    DanSVHO's Avatar
    Join Date
    Jul 2015
    Location
    Delray Beach, FL
    Posts
    888
    +1
    88
    19 Fx svho 20 hours deans stage 3 intercooler tune With all supporting modifications including retainers and fuel pump. 8800 rpm
    Quote Originally Posted by Super Jim View Post
    How many hours? Stock tune? What mods?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. strange
    By Dingram in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-06-2018, 12:58 PM
  2. Something Strange
    By MSRXP in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 12-18-2010, 12:14 AM
  3. this is strange
    By jusloungin in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 04-27-2010, 09:01 PM
  4. Strange Strange How can this be?
    By JohnCiccarelli in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 01-27-2009, 05:43 PM
  5. Seems Strange
    By Keddano in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-11-2007, 12:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •