Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24
  1. #11
    dealer was not local, part is an easy swap, if this fixes the problem, i will report what the fix was / is...

  2. +1 by:


  3. #12
    This weekend, 1/2 of my summer will have been pissed away because of kawasaki motor corp... 2 brand new 2019 310's defective out of the crate. I have been kawi's test dummy for the last 4 weeks to no avail. we made our first payments before our first ride, have spent nearly 300.00 on gas, tolls, ramp fees, siphon pumps, spark plugs. I have been a loyal customer for 20 years, purchased 7 brand new skis and a couple kawi dirt bikes have encouraged all my jet ski buddies to buy kawis and stay away from sea doo and the cheap plastic toys yamaha calls waverunners...

    Kawasaki is claiming to have 5 units that behave like our,,, i bought a red 310x and a 310r, dont know how many 310s kawi produces each year, but I probably have better luck winning the lottery than getting 2 out of the 5 defective skis....

    Their so called fix for these skis hasn't worked, and even if it did work, its just a band-aid for a deeper rooted problem.

    Im beyond pissed off at this point and feel kawasaki should have either bought them back or replaced them.

    lot of good my 5 year extended warranty is doing !!!!

    sure wish HONDA would get back in the game !

  4. #13
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,571
    +1
    166
    Sounds like a bad dealer more than Kawasaki, Are you sure the dealer has even contacted them? Why you spent a dime on bad out of the box ski's is beyond me. Other than the original fill up, no other money should have been on your dime, all the DEALERS.
    Got a case # from Kawasaki? Dealer should be able to provide that if he opened one and you can call them and explain the issues, See if they are even aware. Find out what KAWASAKI will do, not what the dealer tells you.

    Good luck!


  5. #14
    I had similar problem, luckily I was able to find a better dealership with an infinitely better service department. You might try to find out who the Kawasaki Regional rep is and bend that person's ear too.
    Good luck!

  6. #15
    My dealer was in direct contact with kawi tech in california... They admitted to experiencing this problem with 5 units. they thought the quick fix was to send me replacement parts rather than wait for 2-3 weeks for service as most of the dealers are backlogged. needless to say,, the 2 different replacement units did not solve the problem and wasted 2 weeks. Then dealer offered to replace both units on a friday, and told me that he had it 90% worked out and would be shipping me 2 new units, then on the following tuesday said kawasaki refused repalcement until officially seen by a kawi mechanic. Then that week kawi corp. customer service called me and gave me 2 service log numbers and told me to get them to my local dealer and they would be seen by regional kawi master tech and be handling these units personally. again needless to say, the dealer knows of any such master tech and would look as my skis as soon as they could, yet another week gone.

    Then the dealer tells me that kawi tech support says that replacement parts from previous years models are known to fix the issue, but all parts have the same part number so they dont know what they will get... and they only water test once a week... This again will turn into replacement part trial and error wasting even more of my summer.

    I am at my boiling point, and called the kawi customer rep. tell her these skis were defective out of the crate, kawi should buy these back and have 2 water tested machines on my trailer waiting for me. I should not be their dest tummy and waste an entire season figuring out their problems. already cancelled 1 vacation and may have to cancel another trip to the 1000 islands in august.. I'm fed up and pissed off.. both at the dealer and kawi.

  7. #16
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,408
    +1
    345
    Hey Chris; U know I have owned all 3 major brands and even a Honda for good measure. I can honestly say that I’ve had major problems with all Of them over the years (except the Honda, but not enough hours on that ski to judge). U are not alone. I hope that makes U feel a little bit better anyway...

  8. #17
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,408
    +1
    345
    Just curious; what was the part they were trying to swap out for a possible fix?

  9. #18
    ECU and now they tell me that ecu from 15 are known to fix the problem,,, but they all have the same part numbers...

    kawi tech support in CA sent me an old ecu, and the ski's did run better but not 100%, especially the R was still pretty bad.

    My argument with kawi is i should be able to walk into any kawi dealer buy an ecu for my 2019 current year ski and have it work,,, and if it doesnt, there is some other deeper rooted problem that an old ecu is masking and not REALLY fixing the problem...

    been a kawi fan boy for 20 years,,, the first hint of a problem and i am not getting any where with them...

    I will never fully trust these skis that something isn't wrong with them unless they tell me they found the source of the problem and not a BAND-AID FIX !
    Last edited by Chris288; 07-30-2019 at 06:11 PM.

  10. #19
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,408
    +1
    345
    Yeah Man, I hear ya. Hoping everything works out for You sooner than later.

  11. #20
    Thanks, very frustrated ��

    If I was my dealer id eat the cost and make sure my customer was done right by. Not leave me hanging out to dry all summer.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 more 310s with piston issues
    By TJK in forum Kawasaki PWC Performance (4-stroke)
    Replies: 57
    Last Post: 10-24-2018, 09:15 PM
  2. Replies: 5
    Last Post: 07-11-2013, 02:04 PM
  3. Please Help BRAND NEW MSX 110 problem!!!!
    By Bosch Man in forum MSX/Matrix
    Replies: 1
    Last Post: 06-29-2012, 03:19 PM
  4. Please Help BRAND NEW MSX 110 problem!!!!
    By Bosch Man in forum MSX/Matrix
    Replies: 0
    Last Post: 06-29-2012, 02:37 PM
  5. 2004 MSX110 Waste gate problem
    By dfullercps in forum MSX/Matrix
    Replies: 4
    Last Post: 02-01-2008, 02:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •