Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    17 GP 1800 having trouble starting in water

    Having trouble starting ski in water only mod is 8k tune also have new battery. It takes me several attempts to start the ski in water took ski into dealer and they said computer had code regarding possible sensor issue at 10 hours (tune installed then) they said they cleared the code and should be fine but its happening again and getting worse any ideas??? Ski has 62 hours

  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,382
    +1
    1,875
    Whose tune are you using?

    Is the difficult to start symptom consistent if the engine is cold, hot or warm?

    Have you checked whether a sensor is maybe unplugged?

    What sensor was the code for?

  3. #3
    I assumed dealer checked it and from what I remember he said it was ignition sensor and another sensor and both are located in the throttle body and it has to fail completely for the throttle body to be covered under warranty. I have Riva tune and it happens cold, warm or hot.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,382
    +1
    1,875
    Quote Originally Posted by 904Cane View Post
    I assumed dealer checked it and from what I remember he said it was ignition sensor and another sensor and both are located in the throttle body and it has to fail completely for the throttle body to be covered under warranty.

    I have Riva tune and it happens cold, warm or hot.
    You have the Riva MaptunerX device?

    So you could revert to the stock tune for a test?

  5. #5
    Saum700p's Avatar
    Join Date
    Sep 2017
    Location
    New Orleans
    Posts
    347
    +1
    49
    If its not related to the tune, verified by removing the tune, and you push the issue of being left stranded with a ski that won't start they will replace it.

  6. #6
    No I sent the Ecu to Riva, but I really don’t think it’s the tune but maybe I’m wrong ����♂️

  7. #7
    raiderx72's Avatar
    Join Date
    Jul 2007
    Location
    Rocky Hill, CT
    Posts
    727
    +1
    74
    What kind of hard start? Like it's cranking and not firing or cranking slowly? Little more information.

  8. #8
    It'll turn over and act like it's going to fire but doesn't takes several times for it to fire up

  9. #9
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,382
    +1
    1,875
    Quote Originally Posted by 904Cane View Post
    It'll turn over and act like it's going to fire but doesn't takes several times for it to fire up
    Measure the battery voltage while the engine is cranking.

    Perhaps the cranking voltage is sagging more than it should.


  10. #10
    Haven't fallen yet. MJE's Avatar
    Join Date
    May 2007
    Location
    Buzzards Bay, Massachusetts
    Posts
    482
    +1
    40
    I had the same issue after I had it tuned. I have a Dean's tune though. At the same time...the ski is an animal.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP trouble starting in water
    By CBRXP in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-11-2014, 09:45 AM
  2. Engine trouble 1999 sea doo challager 1800
    By Rockarolla70 in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 07-30-2012, 07:52 AM
  3. trouble starting
    By mpp4134 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-08-2012, 06:14 PM
  4. Trouble starting 97 XP
    By jetskr in forum 2-Stroke Performance
    Replies: 7
    Last Post: 09-20-2009, 09:32 PM
  5. Trouble starting
    By CHANDY in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-27-2009, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •