Page 1 of 3 123 LastLast
Results 1 to 10 of 23
  1. #1

    Excessive white smoke RXP 2004..... HELP !!!

    I have this Seadoo Rxp 2005 with excessive white smoke coming out of the exhaust as soon as you start it, the head was decked and new valves replaced and still smoking. Any help will be appreciated.

    Please look at the video on Youtube


  2. #2
    shotgun10ga's Avatar
    Join Date
    Apr 2019
    Location
    Northern Ontario, Canada
    Posts
    31
    +1
    5
    Looks like you're burning coolant...


  3. #3

    Join Date
    Dec 2018
    Location
    Knoxville, TN
    Posts
    54
    +1
    10
    Shotgun nailed it. Was is smoking prior to the head work?

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,216
    +1
    708
    did you reuse the head bolts? Either the head isn't torqued correctly, you have a bad head gasket or someone messed up the deck job.

  5. #5
    dcuhpw's Avatar
    Join Date
    Jan 2019
    Location
    Guam
    Posts
    231
    +1
    7
    Quote Originally Posted by imp0ster View Post
    did you reuse the head bolts? Either the head isn't torqued correctly, you have a bad head gasket or someone messed up the deck job.
    Agreed. Check your head bolt torque and if its good then pull the head and go from there.

  6. #6
    Yes it was smoking the same as it is now thats why i took the head apart and had it decked

  7. #7
    Head bolts are brand new ARP torqued to 100 ft/lbs. Ive done 4 other engines with the same bolts and torque to 100 ft/lbs so i know is not the bolts and torque

  8. #8
    Quote Originally Posted by dcuhpw View Post
    Agreed. Check your head bolt torque and if its good then pull the head and go from there.
    I swapped the head with a different one and does the same thing and i also had the top of the cilinder block swapped to a different and still smoking.

  9. #9
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,572
    +1
    166
    Well time to pressure test the closed loop cooling system and see where the coolant is getting in.
    New head gasket right?
    Coolant bottle drops when running?

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,216
    +1
    708
    then you might have a F'd up jug. Did you look for a melted cylinder wall? If it's torqued properly and the head gasket isn't junk then you have an uneven surface somewhere

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX 110 Excessive smoke
    By CALS in forum MSX/Matrix
    Replies: 15
    Last Post: 08-17-2015, 07:17 AM
  2. 06 RXP Alot of White Smoke
    By mjp in forum 4-Tec Performance
    Replies: 8
    Last Post: 11-24-2014, 10:51 AM
  3. 07 rxp white smoke and bogs at idle
    By redchev67 in forum 4-Tec Performance
    Replies: 10
    Last Post: 05-25-2014, 08:40 PM
  4. gp1200r excessive smoke
    By suckondeez in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-10-2010, 04:57 PM
  5. Need help! White smoke RXP-04
    By Malibu in forum 4-Tec Performance
    Replies: 42
    Last Post: 05-16-2009, 12:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •