Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    NEW to me 2007 Seadoo RTX 215 - a few questions

    Hi
    Thanks in advance for any tips you can give me. I'm not very mechanically inclined and am looking for the likely culprit of a top speed / RPM issue. First, let me say it is the fastest thing i have ever rode. from what i have read RPM's should be around 8200 and a top speed of 66-70 mph. I however am getting RPMs between 7600 and 7740. Top speed between 60-62. I have checked the oil and it's perfect mid level. I am going to check the plugs on Monday but anticipate they will be fine as the dealer said they winterized it. I have driven it for two hours about a full tank of gas and it seems consistent on the RPMs and Top speed. I am wondering if there is any blockage in the intake grill (nothing visible). I'm also ignorant about the supercharger. Does it gradually slow down when it's going out or is it an all at once thing. I am also wondering if some stock skis are just slower than others. Any insights or suggestions would be greatly appreciated.


  2. #2

    Join Date
    Dec 2018
    Location
    Knoxville, TN
    Posts
    54
    +1
    10
    Hate to say it but I suspect that you lost a supercharger washer. I picked up a 2007 RXP 215 last year that was indicating a top speed of about 69 mph then, later in the year, only high 50s. This is how I learned about the bad washers.

    I hope yours is something far more simple.

  3. #3
    Quote Originally Posted by DealsGapCobra View Post
    Hate to say it but I suspect that you lost a supercharger washer. I picked up a 2007 RXP 215 last year that was indicating a top speed of about 69 mph then, later in the year, only high 50s. This is how I learned about the bad washers.

    I hope yours is something far more simple.
    thanks for the response. what's an average repair cost for that?

  4. #4
    RiverRat71's Avatar
    Join Date
    Apr 2016
    Location
    Flint River, GA
    Posts
    460
    +1
    86
    Sounds like the charger is only slipping & haven't "lost" the washer yet. If so you would likely be down more rpm than that. Do yourself a huge favor & don't run it anymore until you have the charger rebuilt. RR

  5. +1 by:


  6. #5
    Quote Originally Posted by RiverRat71 View Post
    Sounds like the charger is only slipping & haven't "lost" the washer yet. If so you would likely be down more rpm than that. Do yourself a huge favor & don't run it anymore until you have the charger rebuilt. RR

    sorry for what is probably a stupid question. what is ththe downside to running it until the washer slips. does it do damage and make for a more costly repair. sorry om fairly ignorant on this

  7. #6

    Join Date
    Dec 2018
    Location
    Knoxville, TN
    Posts
    54
    +1
    10
    Boy, if it’s only slipping you dodged a bullet! Do not run it again. If you loose a washer it breaks into leaves, falls in the oil plan and can cause huge amounts of damage. I got ‘lucky’ as the damage to mine only required removing the engine and replacing both oil pumps and timing chain. You can do a quick search on her and find lots of info.

    SERIOUSLY, DO NOT RUN IT AGAIN! Pull the supercharger and find out what’s going on. It is not a big job.

  8. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,634
    +1
    193
    Quote Originally Posted by gbshabo View Post
    Hi
    Thanks in advance for any tips you can give me. I'm not very mechanically inclined and am looking for the likely culprit of a top speed / RPM issue. First, let me say it is the fastest thing i have ever rode. from what i have read RPM's should be around 8200 and a top speed of 66-70 mph. I however am getting RPMs between 7600 and 7740. Top speed between 60-62. I have checked the oil and it's perfect mid level. I am going to check the plugs on Monday but anticipate they will be fine as the dealer said they winterized it. I have driven it for two hours about a full tank of gas and it seems consistent on the RPMs and Top speed. I am wondering if there is any blockage in the intake grill (nothing visible). I'm also ignorant about the supercharger. Does it gradually slow down when it's going out or is it an all at once thing. I am also wondering if some stock skis are just slower than others. Any insights or suggestions would be greatly appreciated.
    Speed for the 07 RXT should be 63-65 mph @ 8100. 7600-7750 isn’t unheard of ,for stock in the summer heat. Change the plugs, & run high test fuel, to see what the RPM comes up to.
    When was the last time the wear ring was replaced? What state are u in?
    Last edited by psycho rxp; 06-17-2019 at 05:49 AM.

  9. #8
    Quote Originally Posted by psycho rxp View Post
    Speed for the 07 RXT should be 63-65 mph @ 8100. 7600-7750 isn’t unheard of ,for stock in the summer heat. Change the plugs, & run high test, to see what the RPM comes up to.
    When was the last time the wear ring was replaced? What state are u in?
    I'm not sure when the wear ring was replaced. I just purchased the ski at a dealer. I'm driving it in Georgia. it was 80 degrees. I can replace the plugs but What is a high test? The thing has a 30 day limited warranty. If i brought it to them should they be able to identify whether the charger is slipping? I'm kind of leaning towards bringing it to them and having the ceramic washers replaced. Reading the posts above, i had no idea that a supercharger going out could cause thousands of dollars of repairs... I will change the plugs today.

  10. #9
    Your supercharger is WAY overdue for a rebuild. Right now, you are living on borrowed time and driving a time bomb. If those ceramic washers disintegrate, you're probably looking at an engine rebuild. Same goes for the supercharger bearings. Get it rebuilt....... NOW!

  11. #10
    Well I'm convinced. I'm going to take it to the dealer I bought it from see if they will warranty it as part of the 30 day warranty they gave me. Just to understand the process better, when they rebuild the supercharger they should replace the ceramic washer with non-ceramic ones correct?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cluster fault detected by ECM. Seadoo RTX 215 2010
    By acqua in forum 4-Tec Performance
    Replies: 0
    Last Post: 01-31-2015, 08:10 PM
  2. Different questions about the Seadoo RTX-X RS 260
    By EmilSonne in forum 4-Tec Performance
    Replies: 26
    Last Post: 09-15-2014, 11:03 PM
  3. 2007 RXP 215 oil/spark plug questions
    By ygtk09 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-04-2013, 04:57 PM
  4. FS Seadoo RXP RTX 215 255 4tec challenger props!!! 10/21 & 14/25
    By 1fastxpp in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 10-12-2011, 03:08 PM
  5. FS 2007 seadoo 215 engine
    By hydrojunkie in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 10-03-2011, 11:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •