Results 1 to 7 of 7
  1. #1

    97 Kawasaki 1100 zxi. Bogs down after hard spin. What would cause this ?

    I have two separate question and would greatly appreciate any help. I have a 97 Model 1100 zxi. Ada heads 150 psi compression other than that it is stock.
    1st question every time I skip the ski or do a spin it bogs down bad. Have to play with throttle to re again response. I have completely rebuilt all three carburetors thinking it might have been a carb issue.

    2nd question is I noticed there are two of the connections that seal off the dry box broken where could I buy these ? They look like there screwed into the side of the dry box and the wires run thru with a rubber gasket with a cap screwed down to compress the rubber bushing to seal it off.
    Thank in advance for any help.


  2. #2
    jakber's Avatar
    Join Date
    Oct 2017
    Location
    lake travis texas
    Posts
    168
    +1
    1
    Quote Originally Posted by j.warnick70 View Post
    I have two separate question and would greatly appreciate any help. I have a 97 Model 1100 zxi. Ada heads 150 psi compression other than that it is stock.
    1st question every time I skip the ski or do a spin it bogs down bad. Have to play with throttle to re again response. I have completely rebuilt all three carburetors thinking it might have been a carb issue.

    2nd question is I noticed there are two of the connections that seal off the dry box broken where could I buy these ? They look like there screwed into the side of the dry box and the wires run thru with a rubber gasket with a cap screwed down to compress the rubber bushing to seal it off.
    Thank in advance for any help.
    To the first question, are you sure itís a bog and not cavitation? My ultra 150 does something similar in that situation and itís just cavitation from spinning. If itís not cavitation and itís a bog, does it do it at all fuel levels or when youíre lower on fuel?

  3. #3
    All fuel levels..

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,515
    +1
    604
    Does the engine rev up and the 'Ski doesn't move, or does the engine bog down?

    The plastic pieces you need are called 'joints', part number 59071-3001. At least they're cheap.

    If you're running oil injection, have you ever replaced the oil pump bearings? If not, it's time. Also, inspect those oil lines for condition and security. Don't want one to fall off!

  5. #5
    No I premix. No the engine bogs it will take usually a minute or so before it will start running normal again.

  6. #6
    Any ideals or help would be greatly appreciated

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,515
    +1
    604
    You may have water or other trash in the fuel tank that is being pickup up when you spin it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP...Kawi 1100 B1 Bogs on Hard Right Turns
    By ///M5 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 12-11-2018, 12:05 PM
  2. May have a potential solution to the ZXI 1100 hard starting issue
    By atvman in forum Kawasaki PWC Performance (2-stroke)
    Replies: 17
    Last Post: 10-09-2017, 08:19 AM
  3. 96 kawasaki zxi 1100 bogs out after throttle let off
    By kawiguy in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-01-2015, 10:55 AM
  4. 1996 Kawasaki 1100 ZXI - bogs down after 10 mph
    By orlandois in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-01-2010, 11:46 PM
  5. 97 Kawasaki 1100 ZXI
    By MSCARD02 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 10-11-2009, 12:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •