Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,968
    +1
    240
    Just get a piece of pvc pipe a little bigger than the nut, heat it up then slip it over the nut and hold for a few seconds until the pvc hardens up. There is a post here on how to do it, but I cant find it.

  2. +1 by:


  3. #12

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,372
    +1
    92
    Started it up again today and it started super easy what is compression on these motors supposed to be?

  4. #13

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,372
    +1
    92
    Ski finally been out on the water started off ok but then has a couple of issues oil light came on but plenty of oil...any easy way to test sensor?

    Later on it started to loose power, would rev up ok but then die off so ended up limping to back it was als it like reverse cavitation...ski would holes shot strong then loose power rpm if you let off throttle it would then go again before dropping off, any ideas?

  5. #14
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,400
    +1
    133
    If oil light came on add more oil.....

  6. #15

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,372
    +1
    92
    Quote Originally Posted by water worx View Post
    If oil light came on add more oil.....
    Oil tank was pretty full... in fact it was full when started and we’re out less than an hour........was pretty full when checked.

  7. #16
    If the Fuel Lines are Grey , Replace all of them . They have dissolved internally and are sending crap straight to your carbs.

  8. #17

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,372
    +1
    92
    Think lines have been replaced it’s a buddies ski so I’m not able to check easily......

    apperently it was an issue with accelerator pump? Hoping it’s sorted now.

    still have oil gauge and fuel gauge to fix....


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo rxt sat for a year need help!
    By Gray8188 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 06-09-2011, 05:01 PM
  2. 2000 stx 1100 di what to look for before starting sat over winter
    By wakejumper48 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-11-2011, 04:08 PM
  3. WTB: SeaDoo 2-stroke DI fuel pump (any year)
    By boostaholic in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-07-2008, 03:08 PM
  4. Starting a ski that has sat a long time
    By KirkF350 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 08-02-2007, 09:48 AM
  5. Starting new motor that sat for a year
    By mystahagy in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-20-2007, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •