Results 1 to 3 of 3
  1. #1

    Join Date
    Jun 2019
    Location
    Florida
    Posts
    4

    ‘07 Kawasaki Ultra 250x Overheating

    So I have a 2007 Kawasaki Ultra 250x. It only has 40 hours on it, as well as in great condition (inside and out). It starts/sounds great, when being flushed water is exiting PWC in all acceptable exits. The issue is when I am riding, there’s no water coming out of the pisser. Also, last time I rode (month ago), It overheated about 30 minutes into riding and was stranded for about an hour. Any ideas on why the ski would be overheating? Thanks everyone!


  2. #2
    Sounds to me like you have a blockage somewhere in the cooling system between the pump and the exhaust connection. Maybe the filter is blocked.

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,833
    +1
    656
    You've had this problem for a while. Did you pull the strainer off the jet pump and clean it? Did you get the cams synchronized?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ‘07 Ultra 250x Overheating Issue
    By BillyBennett in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 06-05-2019, 10:53 PM
  2. ‘07 Kawasaki Ultra 250x Overheating
    By BillyBennett in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 06-05-2019, 08:31 PM
  3. 07 Kawasaki Ultra LX overheating
    By phonebooth in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 03-17-2016, 05:01 PM
  4. 07 Kawasaki Ultra LX overheating
    By phonebooth in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 03-12-2016, 06:52 AM
  5. 08 Ultra 250X Overheating issues
    By Jackmcd in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 11-14-2014, 05:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •