Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    01 GTX bogs under full throttle

    Hey everyone,

    Just launched my 01 GTX, has the 951 in it, and ran it around a bit. I noticed that Iím hitting around 6500 3/4 throttle, but when I try to open it full throttle it bogs down to around 5500. I tried making my raves flush as they were all the way screwed in but it did nothing. I went through and rebuilt carbs replaced fuel lines and cleaned out the fuel system last season as well as cleaned the raves best I could. Any suggestions to fix this? Could I be looking at a tps issue? Thanks in advance for any help.

  2. #2
    Sounds like a fuel delivery issue,.. check fuel tank,.. fuel pump,.. fuel filter in tank,..ect

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,314
    +1
    126
    Sounds like time for some carb work....

  4. #4
    you say you rebuilt the carburetors ? did you use mikuni parts or were they an aftermarket manufacture?

  5. #5
    Yup, rebuilt the carburetors, it was my first crack at it so I could've messed something up, left all the settings the way they were because the ski ran great in the past. Did however find a leak in my exhaust pipe where it connects to the engine today, only sprays and is evident when you're riding the seat off at faster speeds, which I did just out of curiosity. I pulled my raves hoping and praying water didn't get into the engine and..... well any advice on what actions I should take before it's too late? Will likely be taking it into the shop to make sure things get straightened out. At the very least the plugs aren't looking bad like the raves. Anyone wanna tell me how screwed I am?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	ski1.jpg 
Views:	69 
Size:	70.7 KB 
ID:	449682   Click image for larger version. 

Name:	ski2.jpg 
Views:	69 
Size:	33.9 KB 
ID:	449683   Click image for larger version. 

Name:	ski3.jpg 
Views:	68 
Size:	47.9 KB 
ID:	449684   Click image for larger version. 

Name:	ski4.jpg 
Views:	69 
Size:	66.8 KB 
ID:	449685  


  6. #6
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,314
    +1
    126
    Time to replace the exhaust gasket.

  7. #7
    Thanks for the reply water worx, any ideas on how to get this pipe out? I figure I'm going to have to drop the carbs but am trying to avoid having to split the pipe as its not leaking down there. Do you think I can wiggle that pipe out of the hull without having to split it? The GTX hull with a 951 is a tight workspace

  8. #8
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,314
    +1
    126
    It can be done without removing carbs but you will need the right wrench.http://www.shopsbt.com/jetski/sea-do...1997-2000.html

    On the GTX sometimes I have to remove the motor mount bolts so the motor can move around a little & the pipe will come out.

    Dont use any gasket but the OEM Seadoo one.

  9. #9
    Thanks, will likely need to order that for the reinstall, as it turns out the lazy guys that worked on my ski when I was younger decided not to put that last back bolt in and figured torquing down the other three would be good enough, probably why this leak sprang in the first place.. Will I need to split the pipe?

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    8,149
    +1
    1,943
    you want to avoid splitting the pipe. best to be sure your tech knows how to deal with a 951 exhaust connection or there will be prolonged pain.

    if they don't already own the special wrench, that means they've never dealt with one correctly

    the fiber gasket isn't the best setup, later 951's went to a rubberized o-ring. I use lots of copper exhaust gasket spray on those.a t least two coats and an overnight cure time after assembly

    Make sure the shop uses a torque wrench, failure to do so will result in an eventual repeat of the leak

    how many hours on the motor?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 65u engine bogs at full throttle
    By Shawnblz in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2016, 05:10 PM
  2. Ski bogs down when you push full throttle at a stand still
    By wgmarti in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-15-2016, 08:26 PM
  3. XLT 800 Bogs Down at Full Throttle
    By llaskin in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-23-2009, 10:44 AM
  4. 94 SL750 cuts out and bogs at full throttle
    By raiderman444 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-30-2009, 09:44 PM
  5. 96 SL700 bogs at full throttle
    By Nik33615 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-30-2008, 01:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •