Results 1 to 7 of 7
  1. #1
    Mmafighter's Avatar
    Join Date
    Jun 2011
    Location
    Virginia
    Posts
    423
    +1
    51

    Riva pro cooling system problem

    I keep getting a clog in the left water outlet. I see very little water coming out and the water coming out gets real hot. Sometimes it clogs so bad that nothing but smoke comes out water outlet. Has anyone had a problem like this. Any ideas on how to fix? I take it home and blow it out with a big air compressor tank. Then itís seems ok. Looking for a way to stop having this issue.
    Last edited by Mmafighter; 05-28-2019 at 10:28 PM.


  2. #2
    Mmafighter's Avatar
    Join Date
    Jun 2011
    Location
    Virginia
    Posts
    423
    +1
    51
    93 views and nobody has a clue?🤷🏻♂️

  3. #3
    When you blow it out do you get debris of any sort? Could it be possible it's getting kinked and the air pressure is expanding the kink temporarily?

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,064
    +1
    1,969
    Quote Originally Posted by Mmafighter View Post
    I keep getting a clog in the left water outlet. I see very little water coming out and the water coming out gets real hot. Sometimes it clogs so bad that nothing but smoke comes out water outlet.

    ... Any ideas on how to fix?

    I take it home and blow it out with a big air compressor tank. Then it seems ok.

    Looking for a way to stop having this issue.
    Which way are you 'blowing it out'? By forcing air into the left side hull fitting?

    You may need to take the hoses off inside the hull and see if you have some blockage that you are just pushing back and forth with the comprtessed air and then the water flow.

    Not just the exit hose to the hull fitting, but also the hoses that feed the oil cooler.

    If you drilled out the plastic tee fittings in the cooling water feed path, you may have some plastic debris that was left in the fitting and is now caught somewhere.

  5. #5
    Mmafighter's Avatar
    Join Date
    Jun 2011
    Location
    Virginia
    Posts
    423
    +1
    51
    Quote Originally Posted by K447 View Post
    Which way are you 'blowing it out'? By forcing air into the left side hull fitting?

    You may need to take the hoses off inside the hull and see if you have some blockage that you are just pushing back and forth with the comprtessed air and then the water flow.

    Not just the exit hose to the hull fitting, but also the hoses that feed the oil cooler.

    If you drilled out the plastic tee fittings in the cooling water feed path, you may have some plastic debris that was left in the fitting and is now caught somewhere.
    Thanks

  6. #6
    Mmafighter's Avatar
    Join Date
    Jun 2011
    Location
    Virginia
    Posts
    423
    +1
    51
    Quote Originally Posted by K447 View Post
    Which way are you 'blowing it out'? By forcing air into the left side hull fitting?

    You may need to take the hoses off inside the hull and see if you have some blockage that you are just pushing back and forth with the comprtessed air and then the water flow.

    Not just the exit hose to the hull fitting, but also the hoses that feed the oil cooler.

    If you drilled out the plastic tee fittings in the cooling water feed path, you may have some plastic debris that was left in the fitting and is now caught somewhere.
    Iím gonna check it tonight and see what what I find. Thanjs

  7. #7
    callmeEarl's Avatar
    Join Date
    May 2019
    Location
    DeLaWaRe
    Posts
    46
    +1
    3
    What did you find if anything?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva (and others) Pro Cooling mod
    By LT1GMC in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 02-13-2019, 10:00 PM
  2. Gp 1800 Riva pro cooling pisser keeps clogging
    By Mmafighter in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 12-14-2018, 12:46 AM
  3. lake water cooling system on Wake Pro 215
    By Merc70 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 06-08-2017, 07:34 PM
  4. Riva pro cooling and fizzle installation
    By DanSVHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 34
    Last Post: 02-27-2017, 03:46 PM
  5. SOLD Riva Pro series cooling upgrade kit
    By Captez in forum Yamaha Classifieds
    Replies: 0
    Last Post: 03-11-2016, 01:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •