Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 72
  1. #51
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    4,016
    +1
    849
    Quote Originally Posted by hemikidd View Post
    i went with the 15/22r

    That's a 159mm impeller, you changed your wear ring to 159mm?

  2. #52
    Quote Originally Posted by ptscon View Post
    That's a 159mm impeller, you changed your wear ring to 159mm?

    obviously lol

  3. #53
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    9,333
    +1
    1,628

    I think my suspicions are right

  4. #54
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    4,016
    +1
    849
    Quote Originally Posted by hemikidd View Post
    obviously lol
    Why? You have great 3 or 4 blade options in the proper 161mm size. You're reducing your holeshot and icreasing cavitation with the smaller impeller.

  5. #55
    Quote Originally Posted by troyheb View Post

    I think my suspicions are right

    an what are they =)

  6. #56
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    84
    +1
    5
    Ok so you are at max RPM currently and still lacking speed. Since your pump is now a 159mm putting the stock prop on is not a option at the time. Try adding some pitch to the impeller until you begin to see the RPMs Come down. Also please tell me you didn’t go with the lucky 13

  7. #57
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    84
    +1
    5
    Also check the accuracy of your speedO with a GPS or data logger. My dash showed 81mph early this spring but GPS only recorded a max of 78

  8. #58
    so rebuilt my pump, new stock prop , stock wear ring , JP racing intake rpms are 8179 8200 and speed is 75..... this ski is really starting to get on my dam nerves

  9. #59
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,572
    +1
    2,247
    Have you checked the engine alignment?


  10. #60
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    84
    +1
    5
    What was the temp and altitude when you recorded 75 at 8200rpm

Page 6 of 8 FirstFirst ... 45678 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. ultra lx getting slower and slower... is it the keel guard?
    By JohnnyG. in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 06-10-2012, 06:29 PM
  2. Why is one VX110 slower then the other
    By muttdog in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-05-2010, 02:26 AM
  3. Slower Acceleration
    By dmarvin1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-18-2009, 04:46 PM
  4. I got slower...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-20-2007, 06:03 PM
  5. Who said 06's were slower???
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-13-2006, 11:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •