Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 65
  1. #41
    Lake Lion
    Join Date
    Jul 2007
    Location
    Dirty Jerzey
    Posts
    1,334
    +1
    239
    Did you ever get your speed?

  2. #42
    The riva kits slow you down truthfully. My buddy is running just a SCOM, free flow exhaust and a custom made ram air intake on his 19 RXT-X 300 and hits 79 consistently. Try putting the stock prop back in also, the props on these skis are very good from the factory and the Solas SXX ones have been having quality control issues and exploding in the pumps.

  3. #43
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    78
    +1
    5
    Any updates?

  4. #44
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    78
    +1
    5
    Bump


  5. #45
    overboost's Avatar
    Join Date
    May 2018
    Location
    Earth
    Posts
    137
    +1
    5
    any updates?

  6. #46
    its dead winter where i am, my ski is wrapped up ill be taking it out next month with new prop and all then will see the testing gains

  7. #47
    so heres my update for everyone , i changed my wearring and prop over the winter after speaking with a few people and hearing there results and even speaking with jerry i went with the 15/22r concord impeller so i made UP my rpm im now at 8500 -8550 rpm i got 77 on 3-4 bars of gas BUT as the gas got lower i didnt see anymore speed gains , that was with the stage 2 IMUK tune on mapxtuner, then i put the bone stock 8500 tune and i got 76-77 mph on a full tank of gas as gas got lower NO more speed... wtf is going on here !! i 100% feel a difference in pickup on this prop i like it alot more im getting the RPM i should have gotten but not more speed

  8. #48
    Hemi, how hard was the IMUK to install?

  9. #49
    NitroFish300's Avatar
    Join Date
    Sep 2019
    Location
    Marshall TEXAS
    Posts
    78
    +1
    5
    Quote Originally Posted by hemikidd View Post
    so heres my update for everyone , i changed my wearring and prop over the winter after speaking with a few people and hearing there results and even speaking with jerry i went with the 15/22r concord impeller so i made UP my rpm im now at 8500 -8550 rpm i got 77 on 3-4 bars of gas BUT as the gas got lower i didnt see anymore speed gains , that was with the stage 2 IMUK tune on mapxtuner, then i put the bone stock 8500 tune and i got 76-77 mph on a full tank of gas as gas got lower NO more speed... wtf is going on here !! i 100% feel a difference in pickup on this prop i like it alot more im getting the RPM i should have gotten but not more speed
    are you using another SS wear ring

  10. #50
    Quote Originally Posted by guybb3 View Post
    Hemi, how hard was the IMUK to install?

    not as bad as i thought it would be honestly

Page 5 of 7 FirstFirst ... 34567 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra lx getting slower and slower... is it the keel guard?
    By JohnnyG. in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 06-10-2012, 06:29 PM
  2. Why is one VX110 slower then the other
    By muttdog in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 09-05-2010, 02:26 AM
  3. Slower Acceleration
    By dmarvin1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-18-2009, 04:46 PM
  4. I got slower...
    By Alaska05RXT in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-20-2007, 06:03 PM
  5. Who said 06's were slower???
    By RustySeaRustyDoo in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-13-2006, 11:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •