Results 1 to 10 of 10
  1. #1

    What hoses should go here?!?!

    Hey all, I'm new to the forum, and have only owned my ski for about two years, so if anything is out of order please inform me and forgive me. I had my ski in the shop for nearly 10 months last year, put it in the water yesterday for the first time and had a large amount of water in the hull. I found that this is where it was coming from, and it looks like there is supposed to be hoses there that the shop didn't replace. If anyone has any info that could help it would be much appreciated. Thank you!



    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	water.jpg 
Views:	199 
Size:	89.1 KB 
ID:	448631   Click image for larger version. 

Name:	pump.jpg 
Views:	201 
Size:	60.0 KB 
ID:	448632  

  2. #2
    Cosmicbrut's Avatar
    Join Date
    May 2016
    Location
    NJ
    Posts
    59
    +1
    15
    What year and model ski is it?

  3. #3
    Sorry, it’s a 2012 RXT-X 260. And the pictures are taken in the rear left of the ski.

  4. #4
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    598
    +1
    51

    What hoses should go here?!?!

    There you should be your bailer hoses connected.
    For sure youíll taking in water.
    And one connection is even broken.
    You need to replace that part.

    Or (this is not very good advice) block the broken nipple with some sealant and keep only one bailer hose in use.

    Oh and find yourself another repair shop...........

  5. +1 by:


  6. #5
    Cosmicbrut's Avatar
    Join Date
    May 2016
    Location
    NJ
    Posts
    59
    +1
    15
    Im pretty certain that part which is attached to the ibr actuator is for the lake temperature that shows on bottom left hand part of your digital cluster.

  7. #6
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    598
    +1
    51

    What hoses should go here?!?!

    Quote Originally Posted by Cosmicbrut View Post
    Im pretty certain that part which is attached to the ibr actuator is for the lake temperature that shows on bottom left hand part of your digital cluster.
    No itís not. The hose you see is the incoming cooling line from jetpump. It passes through a cap on the iBr actuator where the temp. sensor sits and from there it splits in 2 to IC and exhaust manifold. This was only on 2010/2011/2012 TX models.

    Only on these years the cooling water and bailer hoses came in under the iBr actuator.

    Horrible design btw.....

    Click image for larger version. 

Name:	IMG_0362.jpg 
Views:	21 
Size:	59.5 KB 
ID:	448639
    Last edited by EVN81; 05-22-2019 at 06:48 AM.

  8. +1 by:


  9. #7
    I thought it looked like a part was broken off, thanks so much. What would be the name of that part, so i can look up replacements and how-to’s? And yea, believe it or not that was the local Sea-Doo dealer. But needles to say they won’t be getting any more of my money.

  10. #8
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,042
    +1
    781
    Click image for larger version. 

Name:	IMG_5345.jpg 
Views:	34 
Size:	82.7 KB 
ID:	448647Click image for larger version. 

Name:	IMG_5346.jpg 
Views:	33 
Size:	57.1 KB 
ID:	448648

    This is how the 2 bailer tubes are connected!

  11. #9
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    598
    +1
    51
    Iím located in Europe and not home for the coming 2 weeks. Otherwise I could you send it to you.
    Have a look here:

    http://partsfinder.onlinemicrofiche....make=seadoopwc

  12. #10
    Cosmicbrut's Avatar
    Join Date
    May 2016
    Location
    NJ
    Posts
    59
    +1
    15
    Quote Originally Posted by EVN81 View Post
    No it’s not. The hose you see is the incoming cooling line from jetpump. It passes through a cap on the iBr actuator where the temp. sensor sits and from there it splits in 2 to IC and exhaust manifold. This was only on 2010/2011/2012 TX models.

    Only on these years the cooling water and bailer hoses came in under the iBr actuator.

    Horrible design btw.....

    Click image for larger version. 

Name:	IMG_0362.jpg 
Views:	21 
Size:	59.5 KB 
ID:	448639
    I stand corrected


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Found pin hoses in these to muffer cooling hoses
    By travis ingram in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-28-2014, 12:15 PM
  2. SC Hoses
    By Waterlogged2 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-28-2011, 12:48 AM
  3. What are these Hoses for?
    By flyguytki in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-09-2009, 12:10 PM
  4. Which Hoses?
    By SE TX Rider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-17-2009, 01:13 PM
  5. Hoses
    By willhbca in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-04-2007, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •