Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13

    96 Sea Doo XP 787 WOT problems

    Hey there!

    So I have a awesome little XP. When I purchased the ski I did a full carb rebuild before I took it out on the lakes. At first it ran great. WOT response was fine. Then slowly it started to bog. Its hard to tell if its happening after I hit waves or if its just random. Thinking it was a fuel issue I switched to Reserve and it would run fine. Then slowly it started happening on both reserve and reg gas lines.

    What will happen is when the throttle is engaged anything more than 60% it will bog down. Half throttle it runs perfect. thinking it may be clogged fuel lines I replaced all of them. Took her out to the river and it ran great!!.... for 20 minutes. Then after it started bogging again at WOT. ... HELP!!

    Is there something im missing here? anything else I should look at?

    Thanks for your help!
    Tony


  2. #2
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    949
    +1
    99
    Quote Originally Posted by Tonydynomite View Post
    Hey there!

    So I have a awesome little XP. When I purchased the ski I did a full carb rebuild before I took it out on the lakes. At first it ran great. WOT response was fine. Then slowly it started to bog. Its hard to tell if its happening after I hit waves or if its just random. Thinking it was a fuel issue I switched to Reserve and it would run fine. Then slowly it started happening on both reserve and reg gas lines.

    What will happen is when the throttle is engaged anything more than 60% it will bog down. Half throttle it runs perfect. thinking it may be clogged fuel lines I replaced all of them. Took her out to the river and it ran great!!.... for 20 minutes. Then after it started bogging again at WOT. ... HELP!!

    Is there something im missing here? anything else I should look at?

    Thanks for your help!
    Tony
    It sounds to me like the fuel pickup baffle is cracked on the inside....causing the problem......easy repair...

    Also the small filters in the carbs can cause a similar issue if the are clogged with debris.....not enough fuel.

    Good luck!

  3. #3

    Join Date
    Sep 2014
    Location
    Southern middle TN
    Posts
    411
    +1
    118
    try changing to new spark plugs and then see how it runs. I have had some run 1/3 to half throttle and then bog. its worth trying.

    could there possibly be any water in fuel? did you clean tank out completely and put in fresh fuel? are you premixing or still have injector?

  4. #4
    Sounds like your fuel switch is drawing in air. It's very common and it will kill an engine by making it run lean. Also check the O-ring in the top of the filter/fuel separator bowl. https://www.ebay.com/itm/OEM-BRP-Sea...wAAOSwZFdaXoOd

  5. #5

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13
    Quote Originally Posted by Matt Braley View Post
    Sounds like your fuel switch is drawing in air. It's very common and it will kill an engine by making it run lean. Also check the O-ring in the top of the filter/fuel separator bowl. https://www.ebay.com/itm/OEM-BRP-Sea-Doo-Fuel-Valve-Part-275500098/142277805228?epid=719294455&hash=item21206b04ac:g: jTwAAOSwZFdaXoOd
    Thanks for the Link! I just purchased that. wont hurt to replace for only 30 bucks. Ill check out the o-rings tonight. Thanks!

  6. #6

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13
    Quote Originally Posted by arctic388 View Post
    try changing to new spark plugs and then see how it runs. I have had some run 1/3 to half throttle and then bog. its worth trying.

    could there possibly be any water in fuel? did you clean tank out completely and put in fresh fuel? are you premixing or still have injector?
    I had brand new plugs in this season when I put it in the water. But I didn't check to see if they fouled. Ill have to check. I had the take completely cleaned out. I still have the fuel injectors going on this ski

  7. #7

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13
    Quote Originally Posted by Hurricane1000 View Post
    It sounds to me like the fuel pickup baffle is cracked on the inside....causing the problem......easy repair...

    Also the small filters in the carbs can cause a similar issue if the are clogged with debris.....not enough fuel.

    Good luck!
    Oh! Never thought of the fuel baffle, Ill have to look into that one this weekend.
    I am not too familiar with the carbs on a ski like I am a dirt bike. But if the rest of the suggestions on here don't work it might be time for me to learn how to clean them since shops cost a arm and a leg lol

  8. #8

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13
    Quote Originally Posted by Hurricane1000 View Post
    It sounds to me like the fuel pickup baffle is cracked on the inside....causing the problem......easy repair...

    Also the small filters in the carbs can cause a similar issue if the are clogged with debris.....not enough fuel.

    Good luck!
    Is the Fuel pickup Baffle also the gas gauge sensor? If so I need to replace it anyways. My Display always thinks im out of gas

  9. #9
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,529
    +1
    242
    If the carbs were plugged with green goo did you scrape out the hose fittings and fuel switch as well?

  10. #10

    Join Date
    May 2019
    Location
    Los Angeles
    Posts
    13
    Quote Originally Posted by Myself View Post
    If the carbs were plugged with green goo did you scrape out the hose fittings and fuel switch as well?
    I took the carbs to a shop to get cleaned. I am still learning ski carbs and I didn't want to mess them up. Last night I starting taking out the fuel switch and there was tons of green goo on it. Pulling all lines tonight and will be replacing them along with the switch and the fuel baffle

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 1997 Sea Doo XP 787 Part out
    By 2smoker119 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 10-15-2018, 10:37 AM
  2. Sea-Doo 1997 787 GTX & 2002 787 GTX RFI
    By Sammy-Ann in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-09-2018, 04:07 PM
  3. FS New Sea-Doo 787 pistons
    By Cody25911 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 03-05-2010, 03:55 PM
  4. 95 sea doo gtx 787 wont go over 40
    By SUCKMYWAKE in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-25-2009, 07:59 AM
  5. WTB Sea Doo 787 Motor
    By Tony Kwolek in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-04-2009, 10:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •