Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Apr 2009
    Location
    Guanaja, Honduras
    Posts
    29
    +1
    2

    2009 fx Sho RPM down, SC Clutch ??

    hey guys,
    looking for some advice, I took my FX out today and the RPMs are down, at first it would go to around 7200 ish and then back down to 6500. at the end of the day it would only go around 6500 and then settle at around 6200. last time i had it out i was getting close to 7400 rpm. it has 104 hrs on it. should i just go ahead a look a clutch ( which one do you recommend) or could it be something fuel related? i was thinking one cleaning injectors and changing fuel pump.
    engines starts and idles perfect, it still have a good punch when i hit the throttle but no top end.

    Thanks!

    Kenric

  2. #2
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,474
    +1
    204
    Doesn’t sound like clutch
    As that is around 5,000 rpm when they are blown


  3. #3

    Join Date
    Apr 2009
    Location
    Guanaja, Honduras
    Posts
    29
    +1
    2
    thats what have me puzzled. I'm thinking probably a weak fuel pump or dirty filter. gas sat for a couple months. I'm going to get injectors clean as first step with new spark plugs. then fuel pump as i have one on hand and last the SC Clutch.

    Quote Originally Posted by fx160 View Post
    Doesn’t sound like clutch
    As that is around 5,000 rpm when they are blown

  4. #4
    SOV's Avatar
    Join Date
    Nov 2014
    Location
    Cluj-Napoca, Romania
    Posts
    167
    +1
    4
    Hi,

    check the intercooler too, if there is a leak you will loose around 1000rpm.

    S.

  5. #5

    Join Date
    Apr 2009
    Location
    Guanaja, Honduras
    Posts
    29
    +1
    2
    Hey guys i cleaned the injectors but still the same, next im going to chnage plugs then fuel pump and last SC clutch.
    i got a little video clip today
    any advice please post!


  6. #6

    Join Date
    Apr 2009
    Location
    Guanaja, Honduras
    Posts
    29
    +1
    2
    If i hold the throttle Full open it settles then if I let go a bit and wot again it goes 7000 for a brief moment

  7. #7

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,195
    +1
    78
    Could be throttle body issue normally get a code any codes?

    Have you checked clutch? SC spins one way only? Same on water and on land?

    Quote Originally Posted by Kenrico View Post
    If i hold the throttle Full open it settles then if I let go a bit and wot again it goes 7000 for a brief moment

  8. #8
    Outboardjohn's Avatar
    Join Date
    Nov 2017
    Location
    Escondido, Ca. 92026
    Posts
    304
    +1
    54
    I'd be looking for a boost related leak, throttle body as mentioned or Intercooler hose. What do the plugs look like?

  9. #9

    Join Date
    Apr 2009
    Location
    Guanaja, Honduras
    Posts
    29
    +1
    2
    Haven’t really reved it that high out of water scares me a bit. Ill check clutch again tomorrow, have to take out the riva air filter No codes.
    Ill be pulling plugs tomorrow and replacing with new ones i got in this evening.
    Another thing tonight getting home from work i tried to start it up and it would just start stumble and quit. Did this maybe 8 to ten times before i got a stable start, starts after that were perfect. Seems like the fuel pump loosing prime. Or injectors got worse after cleaning, don't know.
    how can i check if the throttle body is opening all the way? Or working properly? I remember my vx110 cycles the TB when you power up without cranking. Is the Sho the same?

    thanks a million guys! I really appreciate the feed back. Ill keep you updated on my findings

    kenric

  10. #10

    Join Date
    Apr 2015
    Location
    Wales, UK
    Posts
    1,195
    +1
    78
    Get yds off eBay for $75 just need older windows laptop to make it work

    seller in lithuania is one I used and recommend ships worldwide

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2009 fzs rpm and top speed problem,,, Im assuming its the clutch
    By Chris288 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 10-16-2018, 02:30 PM
  2. FS - Parts Used 2009 SHO Clutch and Gear- Good condition
    By smacota1 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 11-03-2015, 11:57 AM
  3. Which Clutch setup is the best for FX sho 2009
    By Alesi in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-08-2015, 12:57 AM
  4. SHO limited to 5500 RPM's - Broken SC Clutch, Or?
    By WP3223 in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 05-11-2014, 04:37 AM
  5. FS SOLD ! FZ/Sho 2009 Clutch Assembly
    By maxadrenaline in forum Yamaha Classifieds
    Replies: 3
    Last Post: 10-14-2011, 09:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •