Results 1 to 6 of 6
  1. #1

    Ok I am totally stumped here

    Today I worked on a super clean 07 rxt was starting then would die sounded just like fuel pump. gave message sensor at first.
    I connected scantool and its giving 4 p codes p1592 p1590 p1690 p1692 and now wont start wth this ski don't even have vts.
    Tomorrow going to check fuel pressure but still the codes? giving fault and cant clear

    Please words from the wise?

  2. #2
    Pacer's Avatar
    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    442
    +1
    75
    I just had an 07 rxt with a bad ecu. Throwing random codes and then died altogether. I spoke with a dealer that said he has had several ecus go bad in 07 skis. Good luck.


  3. #3
    Quote Originally Posted by Pacer View Post
    I just had an 07 rxt with a bad ecu. Throwing random codes and then died altogether. I spoke with a dealer that said he has had several ecus go bad in 07 skis. Good luck.

    Replaced the ecu last year spring the lanyard pulled would not kill engine.

  4. #4
    Pacer's Avatar
    Join Date
    Jan 2006
    Location
    Patterson La
    Posts
    442
    +1
    75
    Rut Roh. Thatís exactly how the ECU failed on the RXTX. The engine would kill with the start stop button, but pulling the lanyard did nothing. Had to disconnect the battery to shut off the computer. It finally died completely. I bought a replacement used ECU online and it was bad also. Ski acted like it had a low rev limit. I know a dealer, and he checked it out on buds, saw several codes that made him believe it was a bad ECU. Installed a known good ECU and the ski ran like it was supposed to.

    I changed the DESS post while trying to diagnose the original ECU and it still would not shut off when the lanyard was pulled.

  5. #5
    No Pacer I worded it wrong I guess this is a customers machine. last year I installed a new genuine brp ecu to fix that issue. Ran great all last summer. now its a whole different issue it throws code saying the vts shorted to ground ect. and ski doesnt even have vts

  6. #6
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,659
    +1
    508
    you will need to turn off the vts in the ecu settings
    for what ever reason these old skis forget some ecu settings most use candoo but you can use buds

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Totally dumb
    By scopeusa in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 04-12-2014, 09:46 AM
  2. Totally Stumped on Start for 02 4 tec. Need EXPERTS!!!!
    By Water Wonder in forum 4-Tec Performance
    Replies: 27
    Last Post: 12-04-2011, 08:28 PM
  3. Totally Stumped
    By Orlando in forum Yamaha PWC Performance (4-stroke)
    Replies: 24
    Last Post: 06-13-2011, 10:01 PM
  4. well now im totally lost
    By nitrosportman in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-24-2011, 10:09 PM
  5. Totally Looks Like......
    By RX951 in forum Open Discussion
    Replies: 2
    Last Post: 10-23-2008, 09:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •