Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1

    Polaris Genesis Doesn't go above 5000 rpm

    I have a 2000 genesis with the carbs on it I took it it to the lake and it wouldn't go above 5000 rpm and would stall out at idle. I put it on the trailer and it got up to like 8 & 9k rpm out of the water easy. Got it back home and replaced all the grey lines and opened up the carbs, they seemed to be surprisingly clean. I went through them with some small wire and cleaned it up a little. took it out again and adjusted the idle screw and got it to idle at about 1300 no problem. but now it goes up to 5000 then down to 4000. then back up a little.

    Could it be it just needs a full carb rebuild and adjust?
    Or could it be another problem?

    Also on a separate note on the way back to the dock the steering cable went out and would only turn left. Any suggestions on how to replace it easily or what could be the issue?


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,556
    +1
    1,902
    What happened with the prior electrical problem?

    http://greenhulk.net/forums/showthre...92#post3014492

    The only way to make this machine into something reliable is to go through and check everything. Just addressing individual issues as they present themselves is a recipe for being stranded on the water somewhere. The machine needs to be reliable enough to get you back, not just get you out there.

    The steering cable is mechanical. Inspect how it works, you will find where it has become loose or failed.

  3. #3
    The prior electrical problem is fixed after a new stator and lr module from sbt. It starts up fine and the battery charges at 13+ volts

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,556
    +1
    1,902
    Quote Originally Posted by Corvettemina View Post
    The prior electrical problem is fixed after a new stator and lr module from sbt.

    It starts up fine and the battery charges at 13+ volts
    It can help others who may read your electrical problem thread sometime later if the solution is added to complete the diagnostic story.

  5. #5
    Agreed I will add it right now. Any suggestions on the current problems?

    I am struggling to find the front end of the steering cable is there a diagram somewhere?

  6. #6
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,841
    +1
    218
    I recall the handlebar end of the steering cable on a Genesis is very difficult to access, unfortunately.

  7. #7
    What I am see is that the handle bar must come out and then the whole plastic cover in the front must come out then the 4 bolts on the steering column cover come off making it accessible. Is this true? If so any advice on how to get the big plastic cover off in one piece?

  8. #8
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,556
    +1
    1,902
    Quote Originally Posted by Corvettemina View Post
    What I am see is that the handle bar must come out and then the whole plastic cover in the front must come out then the 4 bolts on the steering column cover come off making it accessible. Is this true? If so any advice on how to get the big plastic cover off in one piece?
    Have you looked at this resource?

  9. #9
    Yeah i was getting all my information from the manual and here. Got it all off, wasn't too bad and the cable is definitely broken. looks like I will be ordering one and be doing a deep cleaning in the mean time.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	steering cable.jpg 
Views:	92 
Size:	55.4 KB 
ID:	448513  

  10. #10
    Regarding the performance issues i believe there is water in the fuel as I emptied the water separator and almost instantly after running it filled up.

    I will put water separator in the tank and let it all evaporate out but as I do that, what do I do to to ensure the carbs and everything is good and adjusted well?
    Last edited by Corvettemina; 05-18-2019 at 10:47 PM.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis 1200 (Carbureted) doesn't rev smoothly above idle
    By hookem91 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-09-2019, 02:46 PM
  2. Freedom 700 Engine RPM Strange between 4000 - 5000 RPM / Top Speed?
    By MattOsta in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-12-2015, 11:13 PM
  3. 2001 Polaris Genesis Reverse gate doesn't work.
    By SeaMore DooMore in forum Polaris Tech Tips and Info
    Replies: 73
    Last Post: 04-23-2015, 03:12 PM
  4. Polaris Genesis won't go over 5000 rpms...
    By thedoc in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-20-2008, 09:55 AM
  5. Genesis at 5000 RPM
    By ncg8r in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-16-2007, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •