Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,104
    +1
    1,839
    Quote Originally Posted by Corvettemina View Post
    Regarding the performance issues i believe there is water in the fuel as I emptied the water separator and almost instantly after running it filled up.

    I will put water separator in the tank and let it all evaporate out but as I do that, what do I do to to ensure the carbs and everything is good and adjusted well?
    Are you referring to the fuel/water separator unit, with a floating red ring inside? That clear container is supposed to be full of fuel when operating normally.

    The red ring will stay at the bottom unless water gets into the separator. The red indicator ring will float on the water but sink in gasoline.

    If you have actual water in the fuel tank the water must be drained out. The water will sit in the bottom of the fuel tank underneath the gasoline.

    If the gasoline is ethanol blend then the ethanol will react with the water. The entire tank contents, both gasoline and water, must be drained out and the tank cleaned.


  2. #12
    Ok so the issue will be in the carburetor adjustments/clean?

    And on top of the gas tank there is a hole. I'm almost positive there is something missing. What is it? It's not really shown in the picture attached but all the other holes are.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	gastank.jpg 
Views:	65 
Size:	66.5 KB 
ID:	448533  

  3. #13
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,104
    +1
    1,839
    Quote Originally Posted by Corvettemina View Post
    Ok so the issue will be in the carburetor adjustments/clean?

    And on top of the gas tank there is a hole. I'm almost positive there is something missing. What is it? It's not really shown in the picture attached but all the other holes are.
    Things will be easier if you reply to the previous questions we post.

    What ‘hole’ is on top of the fuel tank?

    There should be no openings between the tank interior and the engine compartment, except for the fuel and vent hose connections at the top of the fuel sender.

  4. #14
    Yes I was talking about the fuel and water separator, my apologizes I wasn't sure how it worked. Thankfully the red ring is all the way at the bottom.

    The Hole i was referring to is highlighted better in the picture below. i took a better one when i got home.

    I know I am coming across a little scatter minded I am just trying to figure out all the problems with it.

    As for the, what seems to be, a fuel supply issue what should be my next step? Adjusting to book spec?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Inkedhole_LI.jpg 
Views:	58 
Size:	45.6 KB 
ID:	448537   Click image for larger version. 

Name:	fuel-water.jpg 
Views:	60 
Size:	42.8 KB 
ID:	448536  

  5. #15
    I found a lose exhaust hose could that be what's making it only cap out at 5k?

  6. #16
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,104
    +1
    1,839
    Quote Originally Posted by Corvettemina View Post
    I found a lose exhaust hose could that be what's making it only cap out at 5k?
    Ride without the seat (leave seat on the dock), see what RPM it can maintain on the water at speed.

    Then put the seat back on, does the maximum sustained RPM change? If yes = exhaust leak inside the hull.

  7. #17
    I am putting the new steering cable in and i had a quick question. Is the angle on this supposed to be so sharp? it feels as if it is going to break from tension. the angle is not as sharp in the picture because i have the bolt holding the bracket out.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Cable.jpg 
Views:	47 
Size:	29.9 KB 
ID:	448674  

  8. #18
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,104
    +1
    1,839
    Which end of the cable is this? At the handlebar end?

    How do you have the cable routed through the hull?

  9. #19
    That is the handlebar end. My understanding is that it is the same way it came out behind the electrical box and then up

  10. #20
    Do I need to grease the steering cable?

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Freedom 700 Engine RPM Strange between 4000 - 5000 RPM / Top Speed?
    By MattOsta in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-12-2015, 11:13 PM
  2. 2001 Polaris Genesis Reverse gate doesn't work.
    By SeaMore DooMore in forum Polaris Tech Tips and Info
    Replies: 73
    Last Post: 04-23-2015, 03:12 PM
  3. Polaris Genesis 1200 (Carbureted) doesn't rev smoothly above idle
    By hookem91 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 04-14-2014, 03:14 PM
  4. Polaris Genesis won't go over 5000 rpms...
    By thedoc in forum Polaris PWC Performance
    Replies: 6
    Last Post: 06-20-2008, 09:55 AM
  5. Genesis at 5000 RPM
    By ncg8r in forum Polaris PWC Performance
    Replies: 3
    Last Post: 07-16-2007, 11:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •