Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    yea , that isnt the number on the pump,, guess im getting ready for that hackage you stated before lol
    Quote Originally Posted by nmpeter View Post
    LOL someplace embossed on the pump. im home right now so I don't have one sitting in front of me, like you do.

    oe wake pump part # was 267000417

  2. #12
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,877
    +1
    1,892
    best guess:

    the 271001290 pump according to the only post I could find on another forum is an early 03-04 model

    its discontinued but your dealer should be able to confirm this. I don't have access to cross references of old pumps. The part numbers are updated very often

    if it has 10 veins, that's what it is

    bring the pump impeller and wear rings to the dealer and let them sort it. don't forget to tip the parts guy. Some quick measurements and a test fit of the impeller should help you ID the actual vintage of the pump

    hackage strikes(again)

    check for those 4 screw holes I talked about..aand if they are there, pick up some new ones at the dealer. you have to very carefully drill into the ring a little to fit them. it's kinda tricky

    plan on a new pump down the road, the plastic ones are so old and brittle now one good rock ingestion event and they are done

  3. #13
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,877
    +1
    1,892
    And.....?

  4. #14
    so i had it out yesterday and seemed alright, the dealer couldn't cross reference the pump number so, I ended up comparing different rings and matched it to a P/N 271000653, hope this can help someone else
    Quote Originally Posted by nmpeter View Post
    And.....?

  5. #15
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,877
    +1
    1,892
    That will save somebody the hassle for sure thanks for the follow up

  6. #16

    Join Date
    Apr 2018
    Location
    Virginia Beach
    Posts
    25
    Your counsel may be shot causing the speedo not to work. If it is important to you, search your local Craigslist ads and see if you can find someone parting out a GTX with a working counsel that you can pick up for cheap. As someone said before they are very expensive new.

    Just wondering, were you able to look over the ski and test ride before you purchased it? I would do some research of items that could cause issues from lack of maintenance and throughly go through the ski looking for any issues. Also if you have not done so, change oil/plugs in case it wasn't taken care of properly as well. It will help save the day to find any other issues before you put it in the water. Good luck and enjoy your new ride.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. 2015 GTX 155 problems and issues to check when buying?
    By lagoondweller in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 10-08-2017, 06:51 PM
  2. gti se 155 2010 VS gtx wake 155 2005
    By Fvillar in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-12-2017, 05:26 PM
  3. Common Problems on GTX 155
    By osteodoc08 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 03-01-2017, 07:22 AM
  4. FS 2007 gtx 155, 2008 wake 155, 2008 load rite 2 place trailer. $7000
    By Joe Stang in forum Sea Doo 4Tec Skis
    Replies: 6
    Last Post: 12-19-2012, 09:21 AM
  5. Which to buy. 155 HP GTX or 155 GTI SE
    By zone 5 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-08-2007, 08:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •