Results 1 to 9 of 9
  1. #1

    Stereo install on SLT 780

    Yes I decided to do this and I think it came out awesome and I thought I would share what I did so if others wanted to do so they could.

    I used an ebay Pyle bluetooth amp
    https://www.ebay.com/itm/NEW-Pyle-PL...72.m2749.l2649

    Then I got these speakers and pods
    https://www.ebay.com/itm/2-Kenwood-6...72.m2749.l2649

    I mounted the amp on the underside of the hood and the swtich is on the hood. The whole setup is actually installed on the hood and can be removed all together just buy removing the hood.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1054.jpg 
Views:	54 
Size:	75.2 KB 
ID:	448129   Click image for larger version. 

Name:	Screen Shot 2019-05-08 at 5.22.55 PM.png 
Views:	52 
Size:	1,006.9 KB 
ID:	448130   Click image for larger version. 

Name:	Screen Shot 2019-05-08 at 5.23.10 PM.png 
Views:	53 
Size:	1.03 MB 
ID:	448131  


  2. #2

  3. #3
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    I like it.

    Where's your MFD?

  4. #4
    I have had to take it out fix it and reseal it so many times that I just take it out now when it’s on the trailer lol.. it kept getting water in it. I’m down to my last circuit board for it so I’m just being extra careful..

  5. #5
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,618
    +1
    54
    Very cool. Did you do any type of battery upgrade?

  6. #6
    No just a stock Walmart battery that I had to fill my self lol

  7. #7
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Quote Originally Posted by whatnissan View Post
    I have had to take it out fix it and reseal it so many times that I just take it out now when it’s on the trailer lol.. it kept getting water in it. I’m down to my last circuit board for it so I’m just being extra careful..
    Yeah, they are getting hard to find. I have a 780 with most cables bound up I am hoping I can resurrect the MFD off of.

    I have a backup plan to use a small PLC or an arduino if all my MFDs finally fail. 5-7 more years and I won't care anymore.

  8. #8
    Let me know if you go the plc route post how you do it. I’m sick of these mfds on the polaris skis. The pin out is the same on all of them so if you made something for one it should work for all of the polaris skis

  9. #9
    Quote Originally Posted by xlint89 View Post
    Very cool. Did you do any type of battery upgrade?

    I actually installed a second battery. I started to notice that while riding the amp pulled more power than the stator made. I’ll post when I get a chance a pic of the second battery install. I just mounted it in the front storage compartment and I used an extra trailer plug so I could just in plug the battery and take it out to charge it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-08-2019, 05:56 PM
  2. FX stereo install
    By wheresmike in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-14-2017, 06:51 PM
  3. Stereo In My Slt?
    By OLDJETSKIMAN in forum Polaris Open Discussion
    Replies: 16
    Last Post: 10-10-2008, 01:34 PM
  4. Stereo install questions
    By jclairday in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 05-07-2008, 07:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •