Results 1 to 7 of 7
  1. #1

    2017 Kawaski Ultra 310x 50MPH problem

    Hey all! I Have 2017 Kawasaki Ultra 310X bought it new 0Hrs, now at 31 Hrs ski wont go over 50MPH (6k RPM) and i have light grinding noise like bad bearing, gas has been use 93 V=Power shell from day one.
    Before i start taking stuff off the ski just wanted to see if anyone has similar problem or can point me to right direction.
    Thank you!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	42332476_10216920027617186_3144241559063494656_n.jpg 
Views:	179 
Size:	146.6 KB 
ID:	447970  
    Last edited by Choppa83; 05-05-2019 at 12:33 AM.

  2. #2
    Bucky STX-15F's Avatar
    Join Date
    Jan 2019
    Location
    Lake Wisconsin
    Posts
    80
    +1
    13
    We probably need more information, my guess would be you picked up some debris while running your ski too close to the shore rocks, sticks etc. if the grinding noise is coming from the back of the ski I think that would make the most sense. However it’s where the engine is that’s a whole another animal.

  3. #3
    Yep, get a bright flashlight and look into the Pump area. You are likely to find some debris caught on the impeller / Pump housing area. Get a long stick or modified coat hanger and fish that stuff out of there. JB

  4. #4
    Pulled off jet pump today everything looks good prop/impeller is spinning freely so far what can i see looks clean in the back/outside the hull probable next step to check supercharge pulley tensioner. Do i have to pull engine to check hull/shaft bearing?
    Thank you.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0861.jpg 
Views:	122 
Size:	80.3 KB 
ID:	448164   Click image for larger version. 

Name:	IMG_0860.jpg 
Views:	121 
Size:	73.8 KB 
ID:	448163   Click image for larger version. 

Name:	IMG_0862.jpg 
Views:	119 
Size:	83.2 KB 
ID:	448165  

  5. #5
    Bucky STX-15F's Avatar
    Join Date
    Jan 2019
    Location
    Lake Wisconsin
    Posts
    80
    +1
    13
    a little out of my area but sounds like it doesnt want to boost.
    i have a TDI Beetle and it wouldnt go into boost and it shuddered like crazy. my issue was a bad MAF. good luck

  6. #6
    Jet ski has been fixed, new spark plugs did the trick runs like new and i greased everything with Yamaha marine grease. Thank you and hope low speed limit problem i had helps someone (bad spark plugs).

  7. #7
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	C7BA203E-EDE9-44A0-8E15-253AD867488D.jpg 
Views:	66 
Size:	68.9 KB 
ID:	448741  


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts Kawaski Ultra '07 - '10 Ultra Meter cluster
    By pops in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 09-13-2018, 04:32 AM
  2. Kawasaki 310x 2017 throttle surging dead
    By bensmeding in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 08-06-2018, 09:01 AM
  3. 2017 Ultra 310lx Top speed problem
    By Drahcir in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 06-23-2018, 07:31 PM
  4. Pistons in 2017 310X
    By Thopper in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 06-29-2017, 04:46 AM
  5. Both Ultra 250x max speed 50mph....down 20mph!
    By DAM217 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 08-25-2015, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •