Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Polaris SL650 94 has spark but wont start

    I need help!
    I have spark, 130 psi compression, fuel is OK, ground tested but I it wont fire up.

    Which could be the problem?

    it was running fine and all of a sudden it stopped and never started again
    Last edited by matutee; 04-28-2019 at 07:46 PM.


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,536
    +1
    243
    I'm guessing fuel related, especially if the auto shutoff is still there. Shoot a bit of carb cleaner in all three cylinders, reinstall plugs, crank it. If it fires up and runs a couple seconds then you definately have a fuel supply issue.

  3. #3
    Fuel system is ok, Carburetors have been rebuild, New triple fuel pump, replaced complete fuel lines included the ones inside fuel tank, restrictor installed into return line, fuel primer kit installed and working OK

  4. #4
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    2,961
    +1
    61
    Good job, if it has fuel ,compression and spark= it runs !

  5. #5
    Quote Originally Posted by casey67 View Post
    Good job, if it has fuel ,compression and spark= it runs !
    Yes I think so, but it is not running

    I have also changed sparks, spark cups and I cut 1/4” the spark wires too

  6. #6
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,175
    +1
    1,843
    Quote Originally Posted by casey67 View Post
    ... if it has fuel ,compression and spark= it runs !
    And correct spark timing.

    And working reeds.

    Have we determined whether directly priming a cylinder with a small drip of fuel allows it to fire up for a few seconds?

  7. #7
    Quote Originally Posted by K447 View Post
    And correct spark timing.

    And working reeds.

    Have we determined whether directly priming a cylinder with a small drip of fuel allows it to fire up for a few seconds?
    Spark timing: I should check it, the strange think is that it was running great and suddenly stopped.

    Reeds: are new, boyensen.

    I tried a small drip of fuel into cylinders but not fired up

  8. #8
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,175
    +1
    1,843
    Also check battery voltage while the engine is cranking.

    Are you checking for spark using a spare spark plug, leaving all three installed in the engine?

  9. #9
    Quote Originally Posted by K447 View Post
    Also check battery voltage while the engine is cranking.

    Are you checking for spark using a spare spark plug, leaving all three installed in the engine?
    Battery voltage is ok, I checked sparks plugs but not leaving them installed, only seeing if they have spark, but I tried 3 complete sets of new spark plugs (NGK BPR8ES)

  10. #10
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,175
    +1
    1,843
    Quote Originally Posted by matutee View Post
    Battery voltage is ok, I checked sparks plugs but not leaving them installed, only seeing if they have spark, but I tried 3 complete sets of new spark plugs (NGK BPR8ES)
    What is the battery voltage as measured while the engine is cranking?

    The engine needs more battery power to crank at speed with installed spark plugs. Removing the spark plugs 'to check spark' changes the cranking load on the starter motor, allowing the engine to mechanically crank faster.

    Leave a full set of spark plugs installed and use another/spare spark plug to check for spark.

    What color is the spark itself? A bright blue/white or a dim yellowish color?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris virage 800 i erratic tachometer and spark wont start
    By chc3 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 03-26-2013, 09:33 AM
  2. 1992 sl650 ? wont start
    By garrykeddy in forum Polaris Open Discussion
    Replies: 13
    Last Post: 07-10-2012, 07:15 PM
  3. 1993 polaris sl650 wont turn over
    By katz1002 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-08-2009, 10:26 AM
  4. Polaris SL650 wont crank
    By katz1002 in forum Polaris Projects
    Replies: 3
    Last Post: 06-08-2009, 08:30 AM
  5. 1990s Polaris SL650 wont crank
    By katz1002 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-05-2009, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •