Results 1 to 4 of 4
  1. #1

    Join Date
    Sep 2018
    Location
    haskins, OH
    Posts
    148
    +1
    5

    Water leak after exhaust mods

    I have not run the ski since doing the TJ exhaust mod. Today I had them hooked up to the hose to make sure all was good to go after winter storage. Anyway the one I did the exhaust mid to had water in the bottom after running. Turns out I am leaking where the tube comes out the top of the water bix. Tighten the hose clamp a little more and still leaking. I know this isn't ricket science but what am I missing?


  2. #2

    Join Date
    Sep 2018
    Location
    haskins, OH
    Posts
    148
    +1
    5
    Quote Originally Posted by MWHC View Post
    well clamps can walk sideways and be off in the back and look good in the front. that particular hose clamp is pretty big plus its a big rubber lip to push down onto the silencer so make sure that's all good. aside from that, too tight on clamps is a "thing" but doubtful thats your issue....
    Thanks, will check that out tomorrow.

  3. #3

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,981
    +1
    569
    be sure you have pushed the hose that you cut the end off of all the way back down on the box, sounds like it is not totally down all the way to where the hose locks back in the groove on the box ,TJ

  4. #4

    Join Date
    Sep 2018
    Location
    haskins, OH
    Posts
    148
    +1
    5
    Turns out that I didn't have the band clamp around the top of the waterbox tight enough. Reads lots of posts about over tightening being a bad thing. Sure it is on rubber to rubber but the rubber to aluminum needed to be tight.

    Thank you for your replies.

  5. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 750 SS exhaust water leak
    By fxrider in forum Kawasaki PWC Performance (2-stroke)
    Replies: 14
    Last Post: 08-15-2018, 05:47 PM
  2. 96 GTX exhaust water leak
    By tbarcia in forum 2-Stroke Performance
    Replies: 22
    Last Post: 08-03-2018, 10:06 AM
  3. exhaust leak and water in the hull
    By p_nells in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-25-2013, 04:42 PM
  4. Water leak at Exhaust outlet
    By Dixieboy in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-09-2010, 02:09 PM
  5. Water leak from exhaust manifold?
    By Anachronism in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-14-2007, 12:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •