Results 1 to 3 of 3
  1. #1
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    657
    +1
    16

    2008 gtx 215 p0339

    Working on a 2008 GTX with a issue of going over 5000 rpm. Acts like it is on the learner key.

    First inspection shows this.

    P0339 code on the mpem 130 hours
    P0339 Crank signal not possible with Cam signal.
    Damaged sensor, damaged circuit wires, damaged connector, damaged ECM pins or damaged tooth wheel.

    Compression 115, 125, 125
    Oil over full about 1/4 inch above the mark on the stick
    DCPR7E spark plugs (yes they are incorrect)
    Low coolant, just a splash in the bottom of the bottle
    Salt water machine
    New rebuild on the supercharger New wear ring and prop.

    I will be lowering the level on the oil, filling the coolant, and installing new spark plugs. I have cleared the codes and I will take it out for a shakedown cruise. I have heard about oil being too full having negative effects on performance but not going over 5000 rpm?

    Anyone have something similar happen? Any words of advise? This is a Florida boat so could I have a wiring harness issue?
    Last edited by diamondwatercraft; 04-28-2019 at 06:53 AM.


  2. #2
    Do what you said and check inter cooler for a leak.

  3. #3
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    Location
    SE Michigan
    Posts
    657
    +1
    16
    The intercooler runs off of lake water. It would have a more inconsistent rpm level if it was leaking. Leaking intercooler does not explain the 5000 rpm limit and the code? This is acting like its on the learner key or limp mode but no evidence of learner key operation is on this machine. It seems electrical.

    Is there a bench test for the Crank positioning sensor or cam sensor?
    Last edited by diamondwatercraft; 04-28-2019 at 06:54 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD 2008 GTX 215-Parting it out!!!
    By carlosdelgado in forum Sea Doo Classifieds
    Replies: 13
    Last Post: 04-21-2019, 10:27 AM
  2. Pump Housing for 2008 GTX 215
    By RIVERSKIER in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2017, 07:29 PM
  3. 2008 GTX 215 Keeps Runnig
    By Brad in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-01-2010, 11:35 PM
  4. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:32 PM
  5. 2008 gtx-215 power loss
    By dallasquick in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-16-2009, 09:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •