Page 46 of 65 FirstFirst ... 36444546474856 ... LastLast
Results 451 to 460 of 641
  1. #451
    Any tips for bleeding the air out of the fuel lines? When I put it on reserve it dies even at idle after about a minute or so. I am not going to try running it on reserve other than at idle in case that is what caused the cylinder to fail last time.

    Also, I still cannot find where those four allen head screws go. They are the identical screws that hold the ride plate to the hull. I guess I will read the service manual cover to cover and maybe spot where they might go. I've looked everywhere that I can think of and I don't see any missing screws.
    Last edited by beekermartin; 07-14-2019 at 07:46 PM.

  2. #452
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,638
    +1
    623
    The fuel pump should draw fuel in just a couple of seconds, no need to bleed the lines.

  3. #453
    Quote Originally Posted by steve45 View Post
    The fuel pump should draw fuel in just a couple of seconds, no need to bleed the lines.
    So then there must be something wrong with my reserve fitting or line? I haven't taken the switch valve apart yet. Maybe I should to see if something is clogged or bad. I will say the same thing happened with the main line until it eventually cleared up. It did take a long time though with double digit stalls before it eventually cleared up. I am afraid to try that again with it set to reserve.

  4. #454
    Good news! I found where those 4 screws go! I am extremely embarrassed to say they hold the intake grate in place! When I was removing the pump the first time I removed a lot more than I needed to. I guess I removed the front and rear grate screws as well. I am very lucky since I did water test it twice without those four screws installed! I got very lucky. I double checked tonight when I was installing the pump with the new impeller and realized my incredible oversight.

    So the good news is I found where they belong and no damage was done. I can only imagine what could have happened if the grate popped loose in the front!

  5. #455
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,638
    +1
    623
    Well? HOW DOES IT RUN?????

  6. #456
    Quote Originally Posted by steve45 View Post
    Well? HOW DOES IT RUN?????
    So far...perfectly for the two short test runs I took it on. This weekend I plan on giving it a good hard test since the new impeller is now installed. I am still nervous since I don't know exactly what caused the lean condition that burned the hole in the piston. I am hoping to get one hard WOT burn for at least 10 seconds that I can then shut down quickly and pull it to shore. Then I can examine the plugs to see what is going on at WOT. That is easier said then done on a ski but I am hoping I can pull it off. Hopefully the plugs show all is good and I can stop worrying and start riding. Time will tell.


  7. #457
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,638
    +1
    623
    Quote Originally Posted by beekermartin View Post
    I am hoping to get one hard WOT burn for at least 10 seconds that I can then shut down quickly and pull it to shore. Then I can examine the plugs to see what is going on at WOT. That is easier said then done on a ski but I am hoping I can pull it off. Hopefully the plugs show all is good and I can stop worrying and start riding. Time will tell.
    Why not just take a spark plug wrench with you?

  8. #458
    Quote Originally Posted by steve45 View Post
    Why not just take a spark plug wrench with you?
    I do and I will. I'm gonna try to do check them after a WOT run the next time out.

  9. #459
    How do these look? After riding it for about 20 minutes I then ran it at WOT for about 20 seconds straight then shut it down. I did have to start it for a split second to change direction though. Also, max RPM was only 6k because of the impeller I had just installed. I think they look good overall considering I am running 50:1 premix and oil injection.
    Click image for larger version. 

Name:	IMAG2751.jpg 
Views:	17 
Size:	64.6 KB 
ID:	451175

  10. #460
    Looks good, but it should still hit 7k. I would be alittle concerned about that

    I think stock equivalent is a 12/18. I would have to look at my skat to see the pitch. Who recommended the impeller you have?

    If i was in your situation i would ship the impeller to impros and have them adjust the pitch and balance. Give them a call let them know what you got and what you want
    Last edited by turboman412; 07-20-2019 at 02:42 PM.

Page 46 of 65 FirstFirst ... 36444546474856 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. Just bought a 2002 Polaris Genesis 1200 need Sponsons
    By srps13 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-18-2015, 09:03 PM
  2. 2002 Kawasaki STX 1200 R
    By 2006 Hayabusa in forum Kawasaki Projects
    Replies: 0
    Last Post: 05-06-2014, 10:37 PM
  3. FS 2002 Kawasaki 1200 STX-R Parts
    By grumpy_steven in forum Kawasaki Classifieds
    Replies: 4
    Last Post: 03-30-2011, 05:47 PM
  4. FS 2002 STX-r 1200 Ski for sale
    By waterman in forum Kawasaki Classifieds
    Replies: 4
    Last Post: 07-11-2010, 12:16 PM
  5. 2002 Kawasaki 1200 STX-R
    By Black Hills TJ in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 04-28-2010, 08:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •