Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44
  1. #31
    Thanks a lot ! Yea it does suck an I love this ski so I’m just going to suck it up see what’s wrong and get it fixed maybe upgrade a few things in the process. My girlfriend is kinda urging me to get a brand new ski but at this point with the stereo I did (way louder than the stock seadoo one by far) and all the other tweaks and time and honestly I like the look and feel of mine better than the new seadoos.. I have a riva fuel pump and I just ordered a fuel presure regulator. I wish I was spending money to go to the 300 charger instead of fixing my motor but ugh this the way the cookie is crumbling right now so I’m just going to clean it up.. hopefully it all works out and everything is better and more reliable than before

  2. #32

    Join Date
    Aug 2013
    Location
    Connecticut
    Posts
    133
    +1
    23
    You're very welcome, i do feel your pain, i know how hard it is to just have had everything perfect and then this goes and happens, i have been there before and its not a good feeling, and i get why your girlfriend wants you to buy a new one but after all the time you spent on the one you have it would be a waste to give up on it now, maybe you could find an engine and harness out of a 300 and swap it in or find a used 260 engine for a reasonable price and then you'll still have the funds to do the 300 charger swap, i cant wait to see what happened to the current engine when you get it torn apart, maybe you can even fix it inexpensively depending on the damage

  3. #33
    So I got to work and Go the ski all taken apart aside from the driveshaft and pulling pump. Got it back on the handi cap cart again ... smh.




    Found this little guy when I tried to lower the IBR to get ready to take off the pump. MY IBR light came on and stopped working when this happened and I lost rpm at full throttle and then it was making that god awful noise. I don't think this caused my issue cause there is plenty of metal in the oil filter that lets me know something is up.. Good news is my IBR works again YAY



    Hopefully Ill get the motor out soon and get it apart and see wtf happened...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1963.jpg 
Views:	86 
Size:	70.2 KB 
ID:	457877   Click image for larger version. 

Name:	Screen Shot 2020-02-04 at 5.22.56 PM.png 
Views:	90 
Size:	807.4 KB 
ID:	457878  

  4. #34
    Quote Originally Posted by Rxtxruss View Post
    You're very welcome, i do feel your pain, i know how hard it is to just have had everything perfect and then this goes and happens, i have been there before and its not a good feeling, and i get why your girlfriend wants you to buy a new one but after all the time you spent on the one you have it would be a waste to give up on it now, maybe you could find an engine and harness out of a 300 and swap it in or find a used 260 engine for a reasonable price and then you'll still have the funds to do the 300 charger swap, i cant wait to see what happened to the current engine when you get it torn apart, maybe you can even fix it inexpensively depending on the damage
    Thank you for the kind words sir, At this point Tesla just went to close to $1000 a share today and I got them back at like $199 and im sick of the bs and the well im going to upgrade this and I eventually want to do this.. I had so much fun for the 2 hours I got to ride my system I did is so perfect and a million times louder than the stock Seadoo system its so baller.. IM kinda just going to say fuck it and go as all out as I can.

    Facts I know at this point motor needs to be rebuild bearings are most likely shot



    if you watch this dudes videos you will see how this engine acts and mine is the exact same. Kinda sounds like its locked on first trying to start up and that light knocking sound that gets loud af when its in the water. The third video in his series one of the pistons spun a rod bearing and mine runs sounds and acts exactly the same.

    I was able to idle it in 15 min ( I know I wasn't supposed to but at that point I know the motor was F*&ked and I just needed to get back.)

    My compression tester might be f'd but my numbers don't look good so it would probably be a good idea to just rebuild the motor assuming the block and all that is good. the head was just done im thinking of just saying screw it and doing valves too I did the superrich springs and retainers and cheeped out on the valves .

    All this bs and pulling the motor again and I have messaged Jesus and he is 100% on board to help me get a tune dialed in no mater what.

    I have come this far with this ski and there is no going back I debated on just getting the 300 charger now and upgrading the wheel later but..... WHY? Im just going to do it all now button it up get the tune perfect might take a couple weeks of figuring shit out but this is the direction im thinking of taking . I would go turbo but with this niche market I know its going to be more expensive and I think the 300 charger with a built right motor will be a reliable fun ski ... I don't even care to hit 90 and all that ( although it would be c00l.. ). IM good with a low to mid 80s ski... Just enough to talk smack and have a good time... Ill be updating as this is all specutlive until I know wtf happened to my motor..

  5. #35
    So sexy but so sad

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screen Shot 2020-02-04 at 6.34.11 PM.png 
Views:	93 
Size:	919.9 KB 
ID:	457889  

  6. #36
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    8,757
    +1
    591
    Following

    Hopefully no issues with crank journals nor rods. Digging that cart the ski is sitting on!!


  7. #37
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,932
    +1
    385
    Quote Originally Posted by whatnissan View Post
    So sexy but so sad

    I feel your pain, I'm convinced my ski was a time bomb in a past life. You did a killer job on the speakers btw!!


  8. #38
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,261
    +1
    2,118
    Quote Originally Posted by whatnissan View Post
    So sexy but so sad


    We will figure it out, Dave. Hang in there, bro!

  9. +1 by:


  10. #39
    So got to tare in to the head today and so far so good!! We couldn't pull the whole motor today because we needed a different drive shaft removal too. (Hey BRP if your reading, ITs been over 10 years lets update this design).. lol. I also got my fuel pressure regulator today! So next step is to get the motor out check the pto and bottom end. I think its its a rod bering bob thinks and I hope he is right that its a flywheel bolt! Also checked the pump to see if it was the impeller that came unscrewed. Good news it wasn't lol.


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screen Shot 2020-02-06 at 5.07.20 PM.png 
Views:	63 
Size:	836.4 KB 
ID:	457951   Click image for larger version. 

Name:	Screen Shot 2020-02-06 at 5.07.02 PM.png 
Views:	65 
Size:	1.03 MB 
ID:	457952   Click image for larger version. 

Name:	Screen Shot 2020-02-06 at 5.06.44 PM.png 
Views:	63 
Size:	1,000.9 KB 
ID:	457953   Click image for larger version. 

Name:	Screen Shot 2020-02-06 at 5.06.34 PM.png 
Views:	65 
Size:	995.7 KB 
ID:	457954   Click image for larger version. 

Name:	Screen Shot 2020-02-06 at 5.06.26 PM.png 
Views:	65 
Size:	769.4 KB 
ID:	457955  

  11. #40
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    8,261
    +1
    2,118
    Quote Originally Posted by whatnissan View Post
    So got to tare in to the head today and so far so good!! We couldn't pull the whole motor today because we needed a different drive shaft removal too. (Hey BRP if your reading, ITs been over 10 years lets update this design).. lol. I also got my fuel pressure regulator today! So next step is to get the motor out check the pto and bottom end. I think its its a rod bering bob thinks and I hope he is right that its a flywheel bolt! Also checked the pump to see if it was the impeller that came unscrewed. Good news it wasn't lol.
    I said the problem could be several things but we've eliminated any head issues, the piston crowns seem to be ok, and that the impeller did not unscrew itself and mess up the thrust bearings. Looking into the cam chain cavity, I did not see any telltale indications of of FW bolts/stator problems, but we won't know for sure until the pto cover is removed. I rather it be that problem than a rod or main bearing problem.

    That said, when this situation arose, I wish you would have pulled the key rather than idled back to the boat ramp.

Page 4 of 5 FirstFirst ... 2345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Seadoo RXP-X 260 impeller recondition question
    By Kirch in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-19-2016, 10:06 AM
  2. Replies: 94
    Last Post: 06-11-2014, 10:01 PM
  3. 2010 RXT 260 7-5K to Build Riva or R&D
    By andreasenracing in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-05-2014, 03:29 PM
  4. RXT-X 260 80mph build stock SC
    By TDR in forum Sea Doo Build Threads
    Replies: 482
    Last Post: 10-17-2013, 09:42 PM
  5. Replies: 24
    Last Post: 10-30-2011, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •