Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    I checked with SBT and they want everything back.

    Looking at my pic and their website, sure looks like the correct ring part # to me, which probably means the cylinders are bored more than 0.5 over. But the pistons fit fine, soooo...

    Heck I am going to measure the cylinders/pistons and post just for posterity.


  2. #12
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Quote Originally Posted by Myself View Post
    Probably mis stamped and packaged wrong. Guessing the ckearance would be ok if you stuck those in a std bore cylinder.
    I will try that as I have a stock cylinder handy.

  3. #13
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    OK, so, in April I bought a core exchange crank and (3) cylinders on a core swap from SBT.

    When I filmed my unboxing vid for those parts and posted it I won $500 worth of credit which I immediately used to buy...another crank exchange and another complete cylinder exchange.

    I know...boring right? I have six 1996 SLT780s...so I was spare parterizing.

    Anyway, from the April cylinders, two of them are oversized by the same amount, I suspect these are 1mm over.

    The other 4 cylinders are fine and the rings fit in them as they should.

    I *did* try the rings in a standard cylinder, and they overlapped as expected.

  4. #14
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Tear down vid:




    Rebuild pt 1:




    Rebuild pt 2:


  5. #15
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    8 hours on the 4th ski today. I am beat and need a shower. I was hoping to get the motor and pump in today and get them aligned, but none of the pump/stator combos I had already separated would come apart. So the 6th ski started it's slow descent into parts today and yielded pump parts I can get apart and service.

    The manual impact screwdriver finally met it's match on the phillips bolts holding the oil tank in, so I broke doen and bought a battery operated impact driver from homedespot. After an hour of charging it took 6 seconds to remove those bolts. Can't wait (no...yes I can) to use it on wheel lugs (removal only) next time I need to do that.

    E-box on this ski looks OK and all sensors test out OK as close as I can tell. I still haven't tested the round MFD, never had one of those before.

    Shower.

    Food.

    Thud.

  6. #16
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Here's an interesting failure I have not seen before.

    This is the wear ring for the impeller. No damage to the impeller, but look at the size of the gouge that has been formed in the wall!


  7. #17
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,627
    +1
    54
    Almost looks perfectly machined. Weird....

  8. #18
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Got everything in the ski except the intake box and the pump, planning to run it some on the hose.

    No spark.

    Check the kill switch, yep, shorted.

    Still no spark.

    Yank the Ebox out and start testing things. Stator is testing bad, but makes no sense.
    -Red/purple to Yellow = 0.6 Ohms OK
    -Red/purple to black = 0.6 Ohms FAIL
    -don't remember the rest

    I'm beating myself up. I KNOW I tested that damn stator before putting it in.

    Doesn't matter, gotta yank the engine.

    As soon as the engine clears the tub I walk around to the port side and see a section of wiring harness mashed flat in an arc.

    Dammit...one too many in-and-outs getting the alignment right and the last one I let the harness get under the engine mount washer.

    Oh well, at least I don't have to pop the front off the engine and find a spare stator. Everything tested fine once I got the wires off each other.

  9. #19
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,627
    +1
    54
    The aligning part sucks.

  10. #20
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    958
    +1
    22
    Back on the ski today.

    Re-install handlebar pad, MFD, hood, hood catch.

    Pump out ran it on the hose a bit with the oil pump lever disconnected until I got oil to all carbs.

    Got everything in again...won't turn by hand.

    Take pump out and it does...OK.

    Again the alignment seems wrong. Will take the impeller out tomorrow AM and do an alignment check.

    This one is driving me nuts.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Next resurrection begins...another 96 SLT780
    By stimpsonjcat in forum Polaris Projects
    Replies: 30
    Last Post: 06-11-2018, 10:23 AM
  2. GPR1500 build finally begins
    By porschemaniac in forum Yamaha Projects & Build Threads
    Replies: 58
    Last Post: 04-12-2015, 07:17 AM
  3. Broke motor mounts on my 03 GPR, build begins...
    By GP03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 07-27-2012, 02:12 PM
  4. Round 4 GPRXP build begins
    By Lvnspeed in forum Conversion PWC Performance Skis
    Replies: 163
    Last Post: 09-20-2011, 08:04 PM
  5. Got all my parts, The Build Begins :) (first build)
    By HallPass in forum Yamaha Projects & Build Threads
    Replies: 1299
    Last Post: 06-26-2010, 03:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •