Results 1 to 2 of 2
  1. #1

    RXP-X sluggish from a dead stop

    I just recently purchased a RXPX 300. It goes like hell if you are cruising along about 25mph or more when I nail it. However from a dead stop, it feels like the power is being slowly ramped in till I get above 20-30 mph before it comes alive. By comparison my old RXP 215 would take off from a dead stop pulling hard from the very beginning.
    Is the 300 supposed to be like that? Any suggestions? BTW it doesn't feel like it's missing or anything just like the power is being held back at lower speed.

  2. #2
    Might sound silly, but are you in SPORT mode?

    this sounds like exactly what it does when in touring mode.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Virage TXi stop dead after 40 minutes
    By polartraveller in forum Polaris PWC Performance
    Replies: 16
    Last Post: 09-06-2017, 07:48 AM
  2. Rxp very sluggish no power
    By rxpsquad in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-10-2011, 06:28 PM
  3. How to STOP your FZS dead in the water!
    By YoYamma in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 03-27-2011, 05:49 PM
  4. rxp-x, running sluggish
    By lightning666 in forum 4-Tec Performance
    Replies: 24
    Last Post: 04-14-2010, 04:55 PM
  5. Replies: 5
    Last Post: 09-15-2007, 11:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •