Results 1 to 8 of 8
  1. #1

    Join Date
    Apr 2019
    Location
    Miami
    Posts
    9

    Rxtx 300 sucked up rope - wont start

    Hi folks,

    after clearing the rope my rxtx 300 sucked up it does not even turn on the gages or start, completely dead... any ideas ?

    once it the rope got tangles into the ski it went off immediately.


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,955
    +1
    250
    Well, start with the basics and go from there.
    1. Battery ok?
    2. Battery connections tight?
    3. Fuses
    4. Was water in the ski?
    5. Dess post.
    6. Jump starter relay, see if it cranks, but you say display is dead too
    7. Check all grounds

  3. +1 by:


  4. #3

    Join Date
    Apr 2019
    Location
    Miami
    Posts
    9
    Quote Originally Posted by SplishSplash View Post
    Well, start with the basics and go from there.
    1. Battery ok?
    2. Battery connections tight?
    3. Fuses
    4. Was water in the ski?
    5. Dess post.
    6. Jump starter relay, see if it cranks, but you say display is dead too
    7. Check all grounds
    thank you - ill check all the basics, initially i was wondering if there was some sort of electrical reset or safety reset that the ski triggered to protect the engine.

  5. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    44,954
    +1
    2,510
    Quote Originally Posted by virtech View Post
    ... - ill check all the basics ...
    Battery cable polarity attached correctly?

  6. +1 by:


  7. #5

    Join Date
    Apr 2019
    Location
    Miami
    Posts
    9
    Quote Originally Posted by K447 View Post
    Battery cable polarity attached correctly?
    Thank you guys - reseating the battery did the trick!

  8. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    9,606
    +1
    2,444
    always use a wrench to tighten battery cables. When you use a screwdriver this sort of problem crops up often.

    Worst when you jump a wake in open water the engine stalls and will not restart..and there are thunderheads on the horizon and jellyfish in the water

    don't ask.

  9. +1 by:


  10. #7

    Join Date
    Apr 2019
    Location
    Miami
    Posts
    9
    Quote Originally Posted by nmpeter View Post
    always use a wrench to tighten battery cables. When you use a screwdriver this sort of problem crops up often.

    Worst when you jump a wake in open water the engine stalls and will not restart..and there are thunderheads on the horizon and jellyfish in the water

    don't ask.
    thanks for the tip.. much appreciated

  11. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    9,606
    +1
    2,444
    I've suggested to east penn for several years to drop the cross point bolts they supply for batteries as this problem is chronic. Also asked them to put some red paint on the hot side of the battery

    I'm not a big oem, so the suggestions seem to never be implemented.

    I keep a small supply of cheap 10mm wrenches I include when somebody buys two batteries as giveways, as I install the batteries bolts tight enough that a screwdriver is useless

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sucked up a rope
    By mfslacker22 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-03-2017, 04:19 PM
  2. Sucked Up Wakeboard Rope---Please Help
    By VXRBlue in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 07-21-2012, 03:30 PM
  3. sucked up rope
    By gdavis in forum MSX/Matrix
    Replies: 5
    Last Post: 09-05-2011, 01:12 PM
  4. I sucked up a rope.
    By traderdoc in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-14-2010, 06:22 PM
  5. Sucked up a rope!!!
    By mattb2179 in forum Yamaha Old School Skis
    Replies: 10
    Last Post: 06-11-2008, 01:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •