Results 1 to 6 of 6
  1. #1

    2007 Honda Aquatrax oil sensor light flashing. Starts and then shuts off

    Aloha Honda community.

    So I had a pretty major jet ski flip a few weeks ago. Tow in surfing 15 waves. I had some plastic panels and the hood that were destroyed but overall I can out of the situation with minor cuts and bruises.

    Luckily I was able to find a parts jetski here on the island of Kauai and was able to put my ski back together like new.

    When I started my ski up today it had trouble starting. Took off the spark plugs and cranked it over and blew out a bunch of water. Cleared all the water out, cleaned up the plugs and it fired right up.

    New problem however was the oil warning indicator came on and cut off my engine. I can start it right up but the the engine shuts back off and the oil indicator starts flashing and a warning beep.


    I flushed the oil and replaced it and same issue?

    Do you think the oil pressure sensor is bad?

    Any ideas would be helpful.


  2. #2

  3. #3
    Photos of my ski after I replaced the hood, center panel and right side plastic panel. Took off an older ski, wet sanded and re-painted. Looks like new.

  4. #4

    Join Date
    Dec 2018
    Location
    Knoxville, TN
    Posts
    68
    +1
    12
    Did you get any water out with the oil?

  5. #5
    Quote Originally Posted by DealsGapCobra View Post
    Did you get any water out with the oil?
    After I took off the spark plugs and cranked the engine the water began to spit out. Once I got everything I could out I put the spark plugs in and it started up. It then released a bunch of water under the ski that had been sitting in the system. I let it run for a minute and then I shut it down so I could change the oil and run water through through the cooling system and flush it out.

    I extracted about 4.7 quarts. It was a bit milky.

    I put a new filter in and filled 4.3 quarts. Now when I started it up it fires up but then shuts down within 5 seconds and flashes the oil icon.

    I unplugged the low oil pressure plug and it had water in it. I blew it out and plugged it back in. As of last night I am still having the same problem. Starts right up but shuts down and flashes the oil icon.

  6. #6
    Update. This morning the ski fired right up and no more shut off or warning indicator. I will change the oil once more because of some water in the oil and hopefully she will be ready to ride!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Honda aquatrax
    By kauaiguy in forum Honda Skis
    Replies: 2
    Last Post: 03-30-2019, 07:28 PM
  2. Oil light flashing, but no code showing
    By seadoo65 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-25-2013, 03:31 PM
  3. 2005 R-12x oil light flashing
    By cigarlust in forum Honda Open Discussion
    Replies: 10
    Last Post: 04-08-2013, 03:00 PM
  4. f12 flashing oil light??
    By faster7581 in forum Honda How To & FAQs
    Replies: 3
    Last Post: 07-10-2012, 10:37 PM
  5. 2002 Aquatrax flashing CODE 8 (Throttle Position Sensor)
    By steelroe in forum Honda How To & FAQs
    Replies: 3
    Last Post: 05-05-2012, 03:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •