Results 1 to 7 of 7
  1. #1
    Ultra 15f's Avatar
    Join Date
    Jan 2014
    Location
    Overland Park, KS
    Posts
    147
    +1
    27

    2016 Kawasaki Stx 15f No Spark

    I have a 2016 15f that has no spark on all wires. There are no codes on the dash. I have replaced coils, roll over sensor, voltage regulator, plugs, and plug wires. I have checked the fuse's all good. Is it possible the ecu is bad is there anyway to test it?

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,511
    +1
    733
    I was going to suggest swapping with the Ultra 15F, but I guess you've got the Immobilizer on the 2016 and the orange switch on the Ultra 15F.

  3. #3
    Rodsatheart's Avatar
    Join Date
    Nov 2014
    Location
    Arkansas SoCal transplant
    Posts
    549
    +1
    50
    Are the injectors firing ?

  4. #4
    Ultra 15f's Avatar
    Join Date
    Jan 2014
    Location
    Overland Park, KS
    Posts
    147
    +1
    27
    Quote Originally Posted by Rodsatheart View Post
    Are the injectors firing ?
    I know i have fuel pressure i will check if they are firing. If they are not firing what would cause that issue?


  5. #5
    Rodsatheart's Avatar
    Join Date
    Nov 2014
    Location
    Arkansas SoCal transplant
    Posts
    549
    +1
    50
    Just me, and i may get corrected, but if there's no spark and injectors arent firing i would suspect the crank or cam sensor whichever it has.

  6. #6
    Ultra 15f's Avatar
    Join Date
    Jan 2014
    Location
    Overland Park, KS
    Posts
    147
    +1
    27
    Checked the injectors they are not working, i know everything is good on this engine because it starts and runs fine on a different harness and ecu. so its either the harness or ecu, is there anyway to test the ecu or wiring harness

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    7,511
    +1
    733
    I think about all you can do is get a schematic of the harness and check it from end-to-end with an ohmmeter.

    Have you checked the kill switch?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2016+ STX-15F spark plug question - changed from earlier models?
    By stevenk2 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 05-11-2019, 02:06 PM
  2. 2016 Kawasaki STX 15f service manual
    By Ultra 15f in forum Kawasaki Tech Tips and Info
    Replies: 2
    Last Post: 07-29-2018, 09:18 PM
  3. 2016+ STX-15F spark plug - change from earlier models?
    By stevenk2 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-04-2018, 10:34 PM
  4. 2006 kawasaki stx 15f engine inside a 2008 kawasaki stx 15f
    By Transport25 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 05-20-2017, 10:41 PM
  5. Kawasaki STX-15F vs Spark
    By WaterDR in forum Sea Doo Open Discussion
    Replies: 54
    Last Post: 03-25-2017, 06:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •