Results 1 to 4 of 4
  1. #1

    Angry 2017 RXPX 300 engine slow to turn over

    Ok folks here's the deal sorry its a long post but i ant to be thorough. So i have a 2017 RXP-X 300 with 36 hours on it the problem i am having is that the engine seems very hesitant to spin over. Ill go through what i have down and my future thought process. Before you ask no it doesn't have warranty due to the dealer fu(kingme over on that part. So after pulling the ski out of a couple month lay up. I fogged the engine and had the battery on a solar charger. I noticed the ski was not spinning over easily. Did a load test on the battery found out it was dead had 2 cells down. So a new battery went in fully charged. Ski still spun over slow. Now i start looking. I checked the starter voltage 9.5 V DC when turning over. Disconnect the starter from the system starter solenoid has 12.5 V DC and the cable has 12.5 V DC. pull the starter and break it down. I do the 180 and bar to bar continuity test all results are about .9 OHM i also do the bar to ground test and get infinite readings. Feel the bearings and they are good so i know the starter is good. I also test ran the starter with jumper cables and it spun fast and hard when not installed in the ski. Ok so next step i think i could be the pump. I pull the pump and the IBR and it all moves by hand nice and easy the wear ring looks great as well so i say the pump is ok. Next stop the pistons i did scope the pistons and they seemed to look ok. (my boroscope camera sucked but i got an idea). I do see the pistons travel up and down when i turn the engine over. Any ideas what to look for next? Supercharger? I'm running out of ideas on what could be binding the engine up. Also i should mention that i do have the TPS code on the ski could that stop the engine from even turning over?


  2. #2

    Join Date
    May 2007
    Location
    Minneapolis MN
    Posts
    962
    +1
    153
    Are you pulling this out of storage and it started fine when you put it in storage? Does the engine fire eventually even though it cranks slowly? I suspect you got a weak battery but it sounds like you are checking the right things.

  3. #3
    The battery is brand new yuasa rated for the ski. i didn't load test the new one but i suppose i should. yeah the ski ran fine when it was put away in November. i haven't done a spark test on the plugs. Also and this is odd when i go through the menu it has a ski mode now its an rxpx and i never installed a ski module could it be something with the CPU that the code got changed nad now the ski is freaking out?

  4. #4
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,461
    +1
    283
    Quote Originally Posted by Madhatter View Post
    The battery is brand new yuasa rated for the ski. i didn't load test the new one but i suppose i should. yeah the ski ran fine when it was put away in November. i haven't done a spark test on the plugs. Also and this is odd when i go through the menu it has a ski mode now its an rxpx and i never installed a ski module could it be something with the CPU that the code got changed nad now the ski is freaking out?
    Ski mode is has always been there, it's a glitch in the computers. If you tap the start button and power up ski, cycle thru menus and skimode appears(only time cycling menus it appears). You can select and engage it. All of them do that...have the funky unofficial ski mode.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2017 seadoo rxpx 300 only 1 hour help
    By Seadoo4life86 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-07-2017, 01:31 PM
  2. FS - Parts 2017 rxpx 300 motor
    By Jonathancrossan in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 05-12-2017, 07:53 AM
  3. 2017 RXPX 300 Riva Powerfilter Install ??
    By Joeram44 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-10-2017, 11:58 PM
  4. 2016 rxpx 300 vs 2017 rxpx 300?
    By overthetop in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-09-2017, 08:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •