Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1

    1100 STX leaking. Need through hull fittings

    Hi all,

    My hull was leaking on one of the through hull fittings for the cooling water. Once taking everything apart, the two fittings for the bilge pump have broken too.
    I suspect that I can't find the fittings on any parts list, as they are probably part of the hull.

    I ordered some genuine ones from a company here in Australia but the thread is not long enough, as the holes go through the hull and the aluminum plate which is mounted from the inside for the jetpump.
    The thread needs to be minimum 40 mm or 1.5784 ″

    Two fittings are for a 5/8 inch hose and one for a 1/2 inch hose. Otherwise all measurements are the same.

    I have attached a picture of the fittings with measurements. Does anyone know where I could get those fittings from?

    Cheers

    Tim

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	thruhull.jpg 
Views:	96 
Size:	34.6 KB 
ID:	445539  


  2. #2
    Three fittings in total.Click image for larger version. 

Name:	20190309_145731.jpeg 
Views:	49 
Size:	73.0 KB 
ID:	445540Click image for larger version. 

Name:	20190309_145847.jpeg 
Views:	49 
Size:	104.5 KB 
ID:	445541

  3. #3
    Load your pics and description on seadoo 2stroke owners page. Or a group in your part of the world. There are parts supply people to help. Also ebay or utube videos. Are you sure its not a hole in stock cast aluminum exhaust underneath where you can not see it. what year is the 1100? Could you use something else to take its place. Im comparing your picks to the stock set up in a Vintage 96 sts 750. We improved in August of 2017. so im not sure im helping much...

  4. #4
    Or your carbon seal. was there any black specks dust?? How much water sinking fast or you noticed this over time.

  5. #5
    I could see the water coming in from the thru hull fitting with the cooling line. The leak in the driveshaft has been fixed. Exhaust is good.
    Unfortunately there are not many people down under, playing and fixing these skis. It's from 2001 or 2002 if I remember correctly. I've got most of the help from the USA and have always been willing to pay the appropriate shipping costs.
    I'm just trying to find someone pointing me in the right direction of a part that fits similar to the original. Been looking everywhere for days and find nothing other than the parts I've ordered and which are too short.
    If nobody can help, I'll just glue them in with 3M 5200 and they'll never come out again or leak. But it would not be me not trying to get it done as original as possible .....

  6. +1 by:


  7. #6
    Rodsatheart's Avatar
    Join Date
    Nov 2014
    Location
    Arkansas SoCal transplant
    Posts
    427
    +1
    33
    Quote Originally Posted by ronrymNr View Post
    Or your carbon seal. was there any black specks dust?? How much water sinking fast or you noticed this over time.
    It's a Kawi. No carbon seal.

    Pops70, You need new aluminum bulk head fittings. Somewhere I have a link to website I'm trying to find. I'll post it when I do.


  8. #7
    Rodsatheart's Avatar
    Join Date
    Nov 2014
    Location
    Arkansas SoCal transplant
    Posts
    427
    +1
    33
    This should work for both. The picture I posted is from Riva's website. You can double check with the folks in the store if you want.

    https://www.4-tecperformance.com/index.php?main_page=product_info&cPath=103&products_id=1163&zenid=qv4le35g2cnee8dunakblja222
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	F99470745.jpg 
Views:	76 
Size:	10.2 KB 
ID:	445542  

  9. +1 by:


  10. #8
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,164
    +1
    519
    So you run in salt water? If so, I'd suggest you find somebody with a lathe to make you some from Delrin or brass. If you go with aluminum, be diligent about flushing.

  11. +1 by:


  12. #9
    Ok .... I've bought some brass parts which will act as the new through hull fittings.
    As they are virtually only hose connectors, I'll glue them in with 3M 5200 fast cure .... they shouldn't be going anywhere after that.

  13. #10

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki STX 1100 Leaking Hull
    By gp1200rider in forum Kawasaki Projects
    Replies: 7
    Last Post: 11-28-2015, 05:48 PM
  2. STX 1100 water leaking into hull. (Not from the hull seal)
    By 1650bullet in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-07-2015, 07:51 AM
  3. 2001 1100 STX D.I. front crank seals leaking
    By carms_us in forum Kawasaki How To & FAQs
    Replies: 5
    Last Post: 07-16-2013, 10:23 PM
  4. 04 STX 12F Water leaking in hull | Questions
    By ncdoo in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 10-19-2012, 10:56 AM
  5. 1100 STX DI Injectors leaking from fuel line clips.. What is the best option?
    By RUNWME in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-01-2010, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •