Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,360
    +1
    193
    I think the '97 has a driveshaft floating carrier bearing. Loosen the hose that's clamped to the hull and try spinning the bearing on the driveshaft.

  2. #12
    I toke the engine out of the wathercraft to check everithing, the wngine rotate now.

  3. #13
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,664
    +1
    1,855
    wow

    that was a significant waste of time

    how did you pull the engine without pulling the pump?

  4. #14
    I unscrew the engine under plate from the mounts, pull the exaust out and pull the engine out, now that i have it out i will do a carburator restauration. Now my problem is with the impeller, it's stucked, i already toke it out but i can't split the driveshaft of the impeller, have some way to unscrew it ?


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. tigershark 1000 monte carlo flush?
    By Fast1994gt in forum Tigershark
    Replies: 2
    Last Post: 10-19-2011, 11:08 AM
  2. 97 tigershark monte carlo 1000 NEED HELP
    By zachrass06 in forum Tigershark
    Replies: 2
    Last Post: 07-06-2011, 11:48 AM
  3. 95 tigershark 900/97 monte carlo 1000 swap
    By codenameziggie in forum Tigershark
    Replies: 0
    Last Post: 07-24-2010, 04:43 PM
  4. FS tigershark monte carlo 1000
    By parrothead306 in forum Tigershark Skis
    Replies: 3
    Last Post: 07-11-2010, 09:45 PM
  5. Tigershark Monte Carlo 1000 progress
    By parrothead306 in forum Tigershark
    Replies: 59
    Last Post: 05-26-2010, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •