Results 1 to 8 of 8
  1. #1
    Wrench's Avatar
    Join Date
    Nov 2010
    Location
    Lawrence, Kansas, United States
    Posts
    187

    2005 GPR1100 will not start....needs throttle body?

    Hi,

    My gpr1100 won't start. Compression is good. I took it to a dealer and it had several active codes. TPS code, battery voltage code, engine temp sensor code, stepping motor code, pulsor coil code.

    The dealer said it needs a new throttle body assembly, parts and labor will be $2000.

    Has anybody seen this issue with these skis? Surely there it's a simple fix.

    Thanks for any help


  2. #2
    Hi. To be honest I have no idea what ski that is. Donít think there is such a thing. At first I presumed you meant a GP800/1200/1300r....but they donít have throttle bodies. Is it a 4 stroke you have maybe ?

  3. #3
    Wrench's Avatar
    Join Date
    Nov 2010
    Location
    Lawrence, Kansas, United States
    Posts
    187
    Well actually it's not mine, but a guy that has asked me to work on it. He said it was an 1100, which i thought was odd also. It is a 2-stroke. I am guessing it is a 1200.

  4. #4
    kmaher's Avatar
    Join Date
    Jul 2015
    Location
    Norton, Ohio
    Posts
    173
    +1
    28
    If it's a 2005, and it's a GPR, it should be a GP1300r. That being the case, it's fuel injected, and it does have a throttle body. I can't say I've heard issues of them going bad, but I have heard of scenarios where the fuel injectors themselves need to be cleaned. Maybe that's the case here?

  5. #5
    Wrench's Avatar
    Join Date
    Nov 2010
    Location
    Lawrence, Kansas, United States
    Posts
    187
    It sure had a lot of error codes found by the dealer to just be dirty injectors. I haven't worked on very many efi skis so I don't have a clue. Yes, it sounded odd that they said it needed new throttle bodies. Other than the TPS and injectors, not much else can go bad.

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,666
    +1
    1,855
    pull the TB and inspect.

    _sometimes a really good cleaning and lube will get it to work ( for a while)

    you can start with some throttle body cleaning spray, but I'd suggest getting some code scanner to see what's going on.

    and of course, the harness needs to be fully looked over

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,368
    +1
    193
    Right down under the pipe by the front cylinder are a couple connectors. If one of those came undone I could see it throwing those codes.

  8. #8
    Wrench's Avatar
    Join Date
    Nov 2010
    Location
    Lawrence, Kansas, United States
    Posts
    187
    Thanks guys

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB Looking for 08 Throttle body
    By joewharton2 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 01-14-2018, 08:23 AM
  2. FS 2005-2010 yamaha vx110 throttle body assembly
    By T-DUB in forum Yamaha Classifieds
    Replies: 3
    Last Post: 10-12-2013, 12:40 PM
  3. WTB WTB RXP T-X throttle leaver / throttle body /
    By islandboy in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 01-09-2012, 10:45 PM
  4. WTB throttle body for 2005 RXP
    By dhoad in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 03-31-2009, 01:00 PM
  5. How to take a part 2005 RXP throttle body? Instructions?
    By Atliens in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-22-2009, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •