Results 1 to 4 of 4
  1. #1

    2011 Kawasaki Ultra 300lx is not running good after intake/exaust r&d upgrades

    Hi everyone. I have a 2011 ultra 300lx that has 29 hours on it. I purchased some upgrade parts from r&d last summer and after I installed them it seemed to ride fine for a few hours. The next time I took it out after a minute or two it started beeping and the code on the screen said OILP. The motor was acting and sounding like was running hot. So I cut it off and got it towed back. It does the same thing when its im my driveway on the hose Runs fine for a min or two and it beeps with the OILP code.. The water coming out of the pisser and bottom pump area is scalding hot after it warms up when its on the hose. I think somehow the water isn't going threw the intercooler properely and not cooling the motor. Does the engine oil go threw the intercooler to cool it down? Im not very experienced in working on stuff. I think I may have put a hose on the wrong thing when I instslled the r&d exaust and intake. Please help me with any advice if you think you know what I did to make my awesome jet ski a bucket. I know I probably should have taken it to a professional but I like to work on my own stuff to save money. Also I have a dead end carreer as a welder in a non union shop. So yeah you guessed it. Poor white trash. So please go easy on me. Im not too bright. I reek or jean shorts and dirt driveways. Try not to rip me too bad. Also I took a retard test in 4th grade. My brothers called me tard test for years. Thanks for helping with any advice if you can.


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,167
    +1
    519
    Don't be so hard on yourself, Gooball! I bet you can weld a helluva lot better than I can!

    Sounds like low oil pressure to me. Have you checked the level? Don't forget that the engine MUST be level when you check it. I use one of those small circular levels, like you see on top of a wheel balancer. I place it on the valve cover. I pull the dipstick out and wipe it off, then stick it halfway into the dispstick tube. I check the oil when in the water and I move the 'Ski around until the bubble is level, then I quickly shove the dipstick in and back out to check the level.

    If it's got oil in it, there are probably several causes of low oil pressure, but I have no idea what is most likely.

    Do you see any oil leaking under the engine?

  3. #3
    No oil leaking anywhere, and it reads full when ski is level. It ran perfect before I decided to add aftermarket stuff to it. I put a speed up thing on it, intake, exaust, blow off valve, water box, scat trak impeller, an exaust plate thing and removed the filter in the exaust. It sounds way too loud now and I hate the sound. Im gonna buy a new filter thing to put back in the exaust to see if that will quiten it. I don't know whats goin on with my oil pressure. My ski has less than 30 hours on it and I don't think the oil pump or cooler are messed up. Is there a way to check to see if they work before replacing a bunch of stuff? I noticed the tensioner swivel bearing thing has a bunch of play in it. When I tried to take the belt off, I had to turn the wrench as hard as I could to get the spring to bend so the belt would come off. I think it may be putting alot of strain on the motor and thay may be its running hot and low oil pressure. I don't know. Any suggestions? Thanks

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,421
    +1
    674
    If the prop wasn't tightened correctly and loctite applied it can come loose and push on the crank and destroy the bearings , causing OILP problem...... do you have any crankshaft float.....


    If so your in for a world of hurt

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Kawasaki Ultra 300x - Music or upgrades?
    By mustang18_2007 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 05-31-2015, 08:56 AM
  2. 2011 Kawasaki Ultra 300X and 300LX info
    By Green Hulk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 109
    Last Post: 09-19-2013, 10:45 PM
  3. FS R & D Ultra 300X/300LX 2011/2012 New ride plate! in water twice!
    By Hurricane1000 in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 01-31-2012, 02:16 PM
  4. 2011 Kawasaki Ultra 300LX Unstable and Dangerous
    By scout495 in forum Kawasaki Open Discussion
    Replies: 177
    Last Post: 09-10-2011, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •