Results 1 to 6 of 6
  1. #1
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,157
    +1
    105

    Fuel Octane 300 RXP

    We have a ski in the shop 2017 RXPX that will only go 7200 RPM...no bells,no whistles & runs good but will only spin 7200.

    Thinking maybe the owner put 87 octane in...cant get a straight answer from him.

    Has anybody done this ?? if so how did it run ???

    Gonna suck fuel out tomorrow & refill with 93 but just wanted to see if anybody has experienced this ?? Thanx


  2. #2
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,744
    +1
    183

    Fuel Octane 300 RXP

    Ski will pull timming on 87 but not for it to run at 7k range , look for bad fuel , boost leak , bad spark plug or clogged injector .

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,157
    +1
    105
    Funny about all the things you posted to checked have been done & verified. Along with fuel pressure,pump,impeller,MPEM new SC new. Its really got us stumped. It runs great & if I didnt know better I would think it was OK but just missing the last 600 rpm.

    Motor was a new BRP approx 6 months ago & ran fine after the install I really think the customer put 87 or 89 octane in it.

  4. #4
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,744
    +1
    183
    Quote Originally Posted by water worx View Post
    Funny about all the things you posted to checked have been done & verified. Along with fuel pressure,pump,impeller,MPEM new SC new. Its really got us stumped. It runs great & if I didnt know better I would think it was OK but just missing the last 600 rpm.

    Motor was a new BRP approx 6 months ago & ran fine after the install I really think the customer put 87 or 89 octane in it.
    Test another ecu on it , possibly one with a tune see what happens .

  5. #5
    Titan_Joe's Avatar
    Join Date
    Jan 2015
    Location
    Pottstown PA
    Posts
    852
    +1
    177
    Did you verify pitch on the impeller is not out of whack? Pump seal is seated properly? Spark plugs?

  6. #6
    12timeworldchamps's Avatar
    Join Date
    Feb 2006
    Location
    Mineral, VA
    Posts
    451
    +1
    9
    No way its just 87 octane. That's what I run most of the time and always see 78-7900 RPMs all summer long. There has to be another underlying problem. I assume from your address that elevation is not an issue either.

    Eddie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel in oil rxp 300
    By Styler690 in forum 4-Tec Performance
    Replies: 4
    Last Post: 11-19-2016, 05:10 PM
  2. Octane for stage 2 rxp 300?
    By mos90 in forum 4-Tec Performance
    Replies: 17
    Last Post: 09-22-2016, 08:26 PM
  3. 98 Octane Fuel in RXP-X
    By Timbo3416 in forum 4-Tec Performance
    Replies: 25
    Last Post: 12-17-2010, 03:27 AM
  4. RXP-X - Low Octane Fuel?
    By Jarrett in forum 4-Tec Performance
    Replies: 11
    Last Post: 09-24-2009, 10:55 AM
  5. Race fuel 110 octane for RXP
    By Bamafanatic in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-13-2007, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •