Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 80
  1. #21
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,903
    +1
    627
    Quote Originally Posted by davus View Post
    Thanks mate.

    Iím in Australia (not sure where you are?) but having trouble finding one here!!

    Dave
    Ahhh damn. Im in the states

    Part # 293710161

    Click image for larger version. 

Name:	IMG_8535.jpg 
Views:	151 
Size:	31.4 KB 
ID:	443244


  2. #22

    Join Date
    Nov 2017
    Location
    Melbourne, Australia
    Posts
    270
    +1
    6
    Quote Originally Posted by Scott View Post
    Ahhh damn. Im in the states

    Part # 293710161

    Click image for larger version. 

Name:	IMG_8535.jpg 
Views:	151 
Size:	31.4 KB 
ID:	443244
    Interesting. I thought it was actually a T piece?.

    How much would you want for it?. I canít find any at all in Australia so happy to ship it.

    Dave

  3. +1 by:


  4. #23
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,903
    +1
    627
    Quote Originally Posted by davus View Post
    Interesting. I thought it was actually a T piece?.

    How much would you want for it?. I canít find any at all in Australia so happy to ship it.

    Dave
    Fitting shown is from a 2018 gtx. Have you searched back on earlier gtx models?

  5. #24

    Join Date
    Nov 2017
    Location
    Melbourne, Australia
    Posts
    270
    +1
    6

    No Lake Temp after upgrading iBR unit

    Yeah they started in 2013 when the sensor was removed from the ibr unit itself.l and converted to external.

    Prior to that the sensor was part of the ibr itself.

    Having said that, the one you pictured would work fine.

    Iíve contacted seadoo in Australia and they donít have any. They are on ĒbackorderĒ with no ETA.

  6. #25
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,903
    +1
    627
    Quote Originally Posted by davus View Post
    Yeah they started in 2013 when the sensor was removed from the ibr unit itself.l and converted to external.

    Prior to that the sensor was part of the ibr itself.

    Having said that, the one you pictured would work fine.

    Iíve contacted seadoo in Australia and they donít have any. They are on ĒbackorderĒ with no ETA.
    Wow that sucks

    I dont have plans to use this, send me a shipping label and you can have it! I would rather see it go to use.

  7. #26

    Join Date
    Nov 2017
    Location
    Melbourne, Australia
    Posts
    270
    +1
    6
    Hi Scott.

    Thanks very much mate. Extremely generous of you.

    Iíve just sent you a PM. Let me know if you get it (Iím using Tapatalk and not sure if the message was sent successfully.)

    Dave

  8. #27
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    399
    +1
    42
    Looks like Scott saved the day. I have a 2002 GTX-DI that I am trying to keep alive. More and more parts are "no longer available. I have had several plastic Ts break and had to custom make them. There is a 20mm fitting that has to 8mm connections making a double T. No longer available." I was able to get several fittings and put them together to get what I needed. Just a thought if you are in a hurry.

  9. #28

    Join Date
    Nov 2017
    Location
    Melbourne, Australia
    Posts
    270
    +1
    6
    Thanks mate.

    The ski itself is working fine at the moment, just reading 199 degrees lake temp! (Which doesnít seem to affect the way it runs).

    Scott certainly has saved the day. Part is on its way from the states and then Iíll have the right reading! (After a bit of additions wiring).

    Dave

  10. #29
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,903
    +1
    627
    Quote Originally Posted by davus View Post
    Thanks mate.

    The ski itself is working fine at the moment, just reading 199 degrees lake temp! (Which doesnít seem to affect the way it runs).

    Scott certainly has saved the day. Part is on its way from the states and then Iíll have the right reading! (After a bit of additions wiring).

    Dave
    Pm sent with tracking info

  11. #30
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    Friendswood, Texas
    Posts
    8,903
    +1
    627
    Shipped yesterday, 1/7/2019. Lets see how long it takes to reach you

    2 weeks? Any takers?

Page 3 of 8 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Wanted 2010 gtx 155 ibr unit
    By cyrillefrenchy in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 01-05-2019, 09:36 PM
  2. WTB IBR UNIT needed !!!
    By Kiwiluvin in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 12-29-2018, 11:52 PM
  3. Anyone has IBR unit for 2010 Seadoo RXTX 260
    By Rch232 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-17-2018, 11:27 AM
  4. Can lake temp be converted over to engine temp?
    By Ryans rebel in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 11-22-2013, 04:27 PM
  5. WTB - Parts Speedometer and lake sending unit assembaly RXP,RXT 07
    By gp1200rider in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 08-29-2012, 01:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •