Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26
  1. #21
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,492
    +1
    685
    Quote Originally Posted by maiko View Post
    Going to test it this weekend and I'm hoping that's it. When I took the IC out and tipped it sludge was flowing freely. So not only were the fins / mesh blocked there was also a bunch of fluid in it.

    Next on my to do list will be the fuel lines and removal / inspection of the pump.

    MS
    Don't waste your time removing the pump at this stage as looking at the pump will do nothing.

    Perform the flow test to see how much fuel the pump can deliver in the 3 sec prime test ( ml's )
    and see what the pressure is at idle and WOT...

    that is all you need to know on the fuel supply side of things,

    Waz

  2. #22

    Join Date
    Aug 2015
    Location
    Melbourne, Australia
    Posts
    26
    +1
    1
    Did the fuel flow test and checks out fine.

    What I did find was that the in line breather valve was blocked on both ends when I blew into it. So as the fuel level in my tank would go down a vacuum was being created and preventing more fuel from flowing freely out.

    I cleaned it and it's good to go now, I also have a spare one off my KX250, it's the one on the left below.

    The one from the ultra has a spring mechanism and the one from the KX has a bearing style setup and allows the air to flow more freely in. Should I put the old one back in, get a new one or throw in the KX style?



    Mike
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	file-26[1202].jpg 
Views:	190 
Size:	82.7 KB 
ID:	444201  

  3. #23

    Join Date
    Aug 2015
    Location
    Melbourne, Australia
    Posts
    26
    +1
    1
    Perfect day for a ride in Melbourne, ski was running perfectly for 45 minutes.It didn’t skip a beat then the same issue happened, performance was went down and it wouldn’t rev past 5500rpm.

    It ran better for for longer after the ic was cleaned. I’m gonna ng to inspect it tomorrow and run a pressure test.

  4. #24

    Join Date
    Aug 2015
    Location
    Melbourne, Australia
    Posts
    26
    +1
    1
    Post ride inspection of the inter-cooler. No need for a pressure test, clearly has water in it and is obviously cracked.


    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	file-27.jpg 
Views:	157 
Size:	89.1 KB 
ID:	444295  

  5. #25

    Join Date
    Jul 2019
    Location
    İSTANBUL
    Posts
    1
    Hi maiko,
    problem çözüldü mü ?

  6. #26

    Join Date
    Aug 2015
    Location
    Melbourne, Australia
    Posts
    26
    +1
    1
    Time to resurrect this thread Weather in Melbourne is getting warmer and daylight saving time is in. Whooo!

    I dropped in a Walbro 255lph Fuel Pump (Kit GSS342). This pump is slightly longer than the OEM one and a little tricky to get into place. I left off the end rubber capping as it doesent fit back in.

    Drained all fuel and cleaned the inside of tank.

    While the pump was out I cleaned the little cylinder with the IN - OUT markings that the pump connects to. I found it was hard to blow though so I filled it up with de-greaser and bam a bunch of black stuff came out.

    Ran the ski for 50 mins. Issue resolved.

    Took a while but I finally got there.

    Thanks for all the folks who messaged me helping out and offering advice.

    Cheers
    Mike


Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help 2013 ultra 300 x
    By bilbao53593 in forum Kawasaki Open Discussion
    Replies: 11
    Last Post: 07-01-2016, 11:05 AM
  2. 2013 ultra lx wont restart after warm sometimes
    By Broncosguru7 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 10-11-2014, 11:04 PM
  3. 2011-12 ultra 300 ECU work correctly on a 2013 ultra 300?
    By jetdave56 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 06-19-2014, 03:37 AM
  4. Kwasaki Ultra 300 X 2013 Engine Oil ?
    By RXP-X 2011 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 01-07-2014, 02:31 AM
  5. 2011 Ultra 300 vs 2013 Ultra 300 any difference in models
    By pierstar in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-09-2013, 12:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •