Results 1 to 7 of 7
  1. #1

    open loop engine temp question

    running a open loop cooling 300 setup with riva 300 reducer disc on my 14 px. also the pump water restictor drilled to 1/2. The engine temp just cruising speed no boost yet as breaking in motor. water temp was 74 deg and display was only at 135-137 deg cruising around for 30 to 45 min. using the mid size reducer in kit. Not sure if should I wait to get into the power to see what temp does. my build is as follows

    Stage 2 Billet Camshaft, Supertech retainers and springs, CP 8.4-1 Pistons, Cometic Head Gasket, Lightened Cam Gear, Aeromotive RRFPR, Aeromotive Stealth 340 Fuel Pump, Riva Aluminum Fuel Rail, Fuel Pump Relay Kit, ET 137+4 , ET SC Cooler, VT1100 Injectors, Fizzle cooler, Skat Trak 16/22 4 Blade, SS Wear Ring, Aqua Sports Open Loop Kit,Riva 300 Water Reducer Disc's, Riva Water Box, Riva Rear Exit, Rad 4 Spacer,
    Last edited by AquaticAssault13; 12-02-2018 at 10:32 PM.


  2. #2

    Join Date
    Jan 2013
    Location
    Clinton Township,MI
    Posts
    42
    +1
    2
    I would get the smaller disc in there and try to get the temps up around 160. I was at 140 and had problems with gas in oil

  3. #3
    I have now put the smaller water reducer in housing where t stat goes. Water temp today was 68 deg water and engine would not go above 141 cruising around steady 5500 rpm. Changed oil and filter just to be safe on this new motor. Pump hose routing goes pump to a 3 way y one goes intercooler (have a small 3 way t to run to et charger cooler then out the stock cooler pisser) then out thru 3/4 fitting dump. other hose from 3 way y goes exhaust manifold, manifold to engine water pump, out thermostat to oil cooler, out cooler to 3/4 dump. still engine temp not getting hot enough

  4. #4

    Join Date
    Jan 2013
    Location
    Clinton Township,MI
    Posts
    42
    +1
    2
    I’m running the 300 routing on my 260 as well and had the exact same issue you have. I also couldn’t get temps much over 140 degrees. I tried the smallest reducer, but in the end I put a 160degree thermostat in and haven’t had any issues

  5. #5
    connorrxp's Avatar
    Join Date
    Dec 2014
    Location
    ontario/Michigan
    Posts
    1,007
    +1
    152
    Run the 300 set up with a 160 thermo and you won't have a problem, if the water you are in is cold put a ball valave to bleed off extra water right after the pump

  6. +1 by:


  7. #6
    should I put stock pump yellow or green re stricter back in?? I have the pink one drilled to 1/2 maybe to mush flow? wont the t stat act like a door when closes and causing no flow to the oil cooler and changing its thermal properties? what about back pressure when t stat closes

  8. #7
    connorrxp's Avatar
    Join Date
    Dec 2014
    Location
    ontario/Michigan
    Posts
    1,007
    +1
    152
    Quote Originally Posted by AquaticAssault13 View Post
    should I put stock pump yellow or green re stricter back in?? I have the pink one drilled to 1/2 maybe to mush flow? wont the t stat act like a door when closes and causing no flow to the oil cooler and changing its thermal properties? what about back pressure when t stat closes
    Water will still get thru the t stat, I run mine at 13mm I think but run a relief and have a whole different cooling system going on. The oil cooler will be fine, your oil temps wont stray far off your engine temps running the engine water thru the oil cooler. It's perfect for racing cuz the oil will get some heat in it when the t stat is closed. Oil usually sits at 180 if I'm at 160 engine temp. The back pressure when the t stat closes is why I run a half inch relief at the pump to bleed off water volume and pressure. I know where to set it for different water temps but usually start the ski with the reilif wide open then close it accordingly.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question engine temp?
    By Copper in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-10-2017, 02:43 AM
  2. Can lake temp be converted over to engine temp?
    By Ryans rebel in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 11-22-2013, 04:27 PM
  3. Replies: 4
    Last Post: 09-29-2013, 11:38 AM
  4. What engine temp should my FX Sho Cruiser be at, check engine light has been coming
    By Dragdaddy71 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-02-2013, 10:00 PM
  5. Engine temp
    By skewman in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-12-2010, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •