Results 1 to 4 of 4
  1. #1
    pnw_jetski_fishing's Avatar
    Join Date
    Jul 2017
    Location
    Astoria Oregon
    Posts
    10

    2015 ultra LX IAC trouble?

    Iíve spent some considerable time searching previous threads, and my problem seems to point to the IAC valve/motor...but not quite. Ski starts up just fine, runs smooth, but if I let off the throttle fast, engine stalls & dies...a lot of what Iíve read points to the IAC unit, other than the stepper motor makes the clicking sound like itís supposed to after a minute or so of the engine not running.

    Iím leaning towards a cleaning issue, just not sure how or with what. Or am I going the wrong direction here with the IAC not being the issue?

    I run my ski as far as 45 miles offshore, so reliability is more important than anything, & I donít mind replacing pending failures, just want confidence that itís the right fix. Iím pushing 400 hours on the ski, with a considerable amount of that being at idle trolling for salmon (Incase that info is helpful diagnosing the problem).

    thanks in advance!!!


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,164
    +1
    519
    Have you read this thread? Somewhat similar problem.

    http://greenhulk.net/forums/showthread.php?t=275721

  3. #3
    pnw_jetski_fishing's Avatar
    Join Date
    Jul 2017
    Location
    Astoria Oregon
    Posts
    10
    Not quite, my problem gets better once warmed up well. And will typically fire back up in one bump of the starter. If I ease off the throttle really slow, it won’t stall...but the last couple trips out that seemed to be getting worse, and more difficult to ease into idle. Thank you for the suggestion though, I’ll keep that one banked away Incase it starts to get difficult to turn over.

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,421
    +1
    674
    Have you replaced the IAC motor recently ?
    From your description i would be 95% confident thats the problem.
    Of course ypu would clean the throttle body at the same time....

    Waz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Real world comparison - 2015 Yamaha FZS vs. 2015 Kawasaki Ultra 310X SE
    By UnleashedBeast in forum Kawasaki Open Discussion
    Replies: 76
    Last Post: 11-16-2015, 08:17 AM
  2. Real world comparison - 2015 Yamaha FZS vs. 2015 Kawasaki Ultra 310X SE
    By UnleashedBeast in forum Yamaha Open Discussion
    Replies: 47
    Last Post: 08-25-2015, 05:46 PM
  3. Trouble with 03 Ultra 130
    By Alboy in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 09-17-2014, 09:14 AM
  4. Ultra 150 Trouble at Idle
    By Wake51 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 06-04-2014, 10:38 PM
  5. ultra 150 engine trouble
    By hooksgp1300 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-18-2009, 07:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •