Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 49
  1. #31

    Join Date
    Jun 2007
    Location
    Long Island,NY
    Posts
    233
    +1
    21
    Thanks.

  2. #32
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    8,815
    +1
    605
    Quote Originally Posted by mario View Post
    Thanks for offer, but I do have dash pack from my ski and Iím going to install it before ride tomorrow.thanks
    Awesome! Keep us posted

  3. #33

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,639
    +1
    947
    Quote Originally Posted by mario View Post
    Thanks for offer, but I do have dash pack from my ski and Iím going to install it before ride tomorrow.thanks
    I took my 16 PX300 out yesterday in the freezing cold FL weather, 84F air temp/73F water
    It ran 73mph with a very full tank of gas average of back to back relatively short runs, full trim up, boost was 12.5psi, RPM 8140, solas 13/18r, riva grate. The riva grate is probably costing me 1-1.5mph. I think the boost is probably a little low maybe 1psi compared to where I think it should be but my px300 has a bunch of hours on it.

  4. #34

    Join Date
    Jun 2007
    Location
    Long Island,NY
    Posts
    233
    +1
    21
    We bay tested ski today , and it ran 75 mph -dash, 8550 rpms and dashpack was showing 15 psi of boost.I think its time to give a try to 13/16 Solas blade.

  5. #35
    Cosmicbrut's Avatar
    Join Date
    May 2016
    Location
    NJ
    Posts
    100
    +1
    18
    Quote Originally Posted by mario View Post
    We bay tested ski today , and it ran 75 mph -dash, 8550 rpms and dashpack was showing 15 psi of boost.I think its time to give a try to 13/16 Solas blade.
    Im just gonna throw this out there. I tested the solas 161 13/16 3 blade vs a solas 159 4 blade 15/19 repitched to a 13/17 back to back a couple years ago on my 14 tx with 137 wheel/cam and supporting mods. The 161 13/16 3 blade spun 8700 and ran 78mph. The 159 4 blade 15/19 repitched to 13/17 turned 9040 at 84 mph. Swapped pumps out at the ramp and did back to back runs. I realize theres a good amount of differences in machines so just food for thought. This was also with the original sx 13/16.


  6. #36

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,639
    +1
    947
    Quote Originally Posted by mario View Post
    We bay tested ski today , and it ran 75 mph -dash, 8550 rpms and dashpack was showing 15 psi of boost.I think its time to give a try to 13/16 Solas blade.
    Let's say for kicks that on a bone stock ski with a scom full tank of gas runs 72.5 mph GPS, call it 74 dash at 8040RPM with 180lb rider....cause that's what mine would run when new. You got something else going on if you're turning an OEM prop to 8550 and only going 75 dash. I'd double check the wear ring, look up through the pump from the bottom. Since it's cold and you have mods, you would want the 13/18 not a 13/16.

  7. #37
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,390
    +1
    55
    Quote Originally Posted by mario View Post
    We bay tested ski today , and it ran 75 mph -dash, 8550 rpms and dashpack was showing 15 psi of boost.I think its time to give a try to 13/16 Solas blade.
    3 blade will run less speed don’t bother 15 pounds of boost running 75 on the dash something is not right at all the motor is making the power something else going on here in the prop/pump

  8. #38
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,390
    +1
    55
    Do you have another pump you can throw in?

  9. #39

    Join Date
    Jun 2007
    Location
    Long Island,NY
    Posts
    233
    +1
    21
    wear ring its new in that ski, when we changed ring pump look ok- no missing /bent veins, intake grate looks ok as well. I'll try to swap pump from another PX in spring ,I'm still not sure which impeller to get for more testing.

  10. #40

    Join Date
    Jun 2007
    Location
    Long Island,NY
    Posts
    233
    +1
    21
    Quote Originally Posted by DinoMite View Post
    Let's say for kicks that on a bone stock ski with a scom full tank of gas runs 72.5 mph GPS, call it 74 dash at 8040RPM with 180lb rider....cause that's what mine would run when new. You got something else going on if you're turning an OEM prop to 8550 and only going 75 dash. I'd double check the wear ring, look up through the pump from the bottom. Since it's cold and you have mods, you would want the 13/18 not a 13/16.
    I'm pretty sure that 8500 rpms ski has run is because winter like weather , -39f wind winds .In summer time motor wont past 8200ish rpms.Oem impeller that is still in ski was pitched for warm temps.

Page 4 of 5 FirstFirst ... 2345 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3RUDE peak Boost numbers
    By Enufpwr in forum 4-Tec Performance
    Replies: 143
    Last Post: 01-24-2010, 09:23 AM
  2. SC Boost Numbers
    By oklagp1200r in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-01-2009, 04:12 PM
  3. Boost numbers
    By RXP Blur in forum 4-Tec Performance
    Replies: 3
    Last Post: 12-23-2007, 02:46 PM
  4. Boost Numbers......
    By blowbyu in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-28-2007, 01:06 PM
  5. stage 1 RXT numbers, is this slow???
    By waverider in forum 4-Tec Performance
    Replies: 27
    Last Post: 04-09-2006, 08:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •