Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
  1. #1

    Seado rxp 260 weird problem TURBO LAG

    I have a rxp 260 with a weird issue. It has serious lag bellow 3000rpm. Almost like turbo lag.

    Supercharger was replaced.

    What should i look for next ?


  2. #2
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    300
    +1
    22
    Is it a new supercharger or a rebuild? Who did the rebuild? The only things that would cause a lag related to the supercharger are slipping washers, damage to supercharger components, or an air leak. Did id start immediately after the reinstallation of the supercharger? We need a lot more details.

  3. #3
    This happened after the whole thing almost burned down. A friend rode it sucked up a rock. Damaged impeller wear ring and impeller housing and kept going. Most of the exhaust components melted. And where replaced. I just noticed today that the muffler is cracking. Could a bad muffler be causing this ?

  4. #4
    Supercharger is a good know unit from another seadoo rxtx 260

  5. #5
    Is there a chance the ic got damaged due to overheating and is leaking.

  6. #6
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    2,745
    +1
    183
    Quote Originally Posted by elias799 View Post
    This happened after the whole thing almost burned down. A friend rode it sucked up a rock. Damaged impeller wear ring and impeller housing and kept going. Most of the exhaust components melted. And where replaced. I just noticed today that the muffler is cracking. Could a bad muffler be causing this ?
    If you have a cracked / broken exhaust then that will cause carbon monoxide to enter the Hull and choke it from fresh air .

  7. #7
    Quote Originally Posted by DR2006RXP View Post
    If you have a cracked / broken exhaust then that will cause carbon monoxide to enter the Hull and choke it from fresh air .
    I took a ride with the seat off and it doing the same thing.

  8. #8
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,091
    +1
    2,803
    Quote Originally Posted by elias799 View Post
    I just noticed today that the muffler is cracking. Could a bad muffler be causing this ?
    YES! your engine is trying to re breath exhaust fumes and it's killing performance.

    You can get a factory replacement waterbox by clicking here to the GreenHulk OEM parts store, or you can get a RIVA waterbox in the Performance Store from the below link

    RIVA Seadoo S3/T3/GTR WaterBox

    Applications: 2012 & Newer Sea-Doo RXP-X (T3) Models 2009 & Newer Sea-Doo RXT/GTX iControl (S3) Models Our Pro-Series Sea-Doo Water Boxes deliver...
    RS16091 $419.95


  9. #9
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,573
    +1
    744
    Grab a $10 carbon monoxide detector and strap it inside the hull, go riding and then check it. If it's not reading 0 than you have an exhaust leak.

  10. #10
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,445
    +1
    143
    Some clarification is needed and as you said riding with no seat ment no difference. Its not exhaust leaking then. Does it Rev up, but not go, then goes, or is it sluggish to rev, then goes. This would explain your issues.
    Your cavitating, from pump damage. Your replace the wear ring and impeller but you said the housing was damaged, Was it replaced? Was the pump shoe damaged too? Is the pump seal in correctly?

    Look in the pump area, thats where your problem lies. An exhaust leak would kill top speed a lot, you say once its over 3000 rpm it goes, so I doubt you are leaking exhaust.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT-X 260 weird problem, yet again...
    By Speedjunky64 in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-31-2018, 05:53 PM
  2. weird problem with turbo not spooling up
    By thegasman34 in forum Honda How To & FAQs
    Replies: 7
    Last Post: 06-16-2013, 01:41 PM
  3. 2012 RXP 260 Turbo Kit ? Which one
    By RXP-X 2011 in forum 4-Tec Performance
    Replies: 25
    Last Post: 06-12-2013, 09:07 AM
  4. FS 2005 Seado RXP Turbo (Mnt)
    By Hecyan in forum Sea Doo 4Tec Skis
    Replies: 22
    Last Post: 10-10-2011, 05:37 PM
  5. 2006 RXP Weird Problem
    By Camy1448 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-17-2007, 06:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •