Results 1 to 10 of 10

Thread: Oil in coolant

  1. #1

    Oil in coolant

    Iíve got a 2007 gti 155. 170 hours.

    The other day I got an oil sensor light. Pulled in, oil was low. Topped oil off but then checked the coolant resivor. Full of oil mixed with the coolant.

    i replaced the oil radiator. Drained the coolant, changed oil. Took it out, 15 minutes into the ride temp sensor started too beep.

    Coolant resivor again full of oil.

    Any chance I just did not get all the oil coolant/oil mixed out the first time?

    or I guess head gasket or water pump seals.

    checked compression, 170 on each cylinder.

    is it possible to change out the impeller seals with engine still in hull?


  2. #2
    I did another flush and the water stayed clean. So I no longer have oil in my coolant. Also I’m not loosing and coolant. However I’m still getting a p1116 code. I replaced the engine temp sensor, no change.

    i pulled the thermostat out and put a 160 in and it’s still getting temp alarm.
    all hoses feel warm or hot. The exhaust j pipe is not hot.

    anyone have any ideas?

  3. #3
    Banned User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    348
    +1
    22
    Sounds like a possible, bad oil cooler leaking on you..

  4. #4
    Oil radiator and oil cooler is the same thing. I replaced it.

  5. #5
    The engine is closed loop, the exhaust is open loop. If the manifold is getting hot you have a problem with open loop system. Check the pump to insure the water cooling intake passage is not blocked. Make sure no hoses are pinched or kinked. If you ride in salt and donít flush properly the passages or hose nipples could be corroded/restricted.

  6. #6
    Quote Originally Posted by andrew1289 View Post
    Oil radiator and oil cooler is the same thing. I replaced it.
    Proper term is oil cooler. Yes same purpose.

  7. #7
    Actually seadoo calls it a radiator. But that’s not important. Also I said the exhaust was cool. About 100 f.

    i connected the ski to budds, I was getting 217f at engine coolant sensor.

    i tryed flushing the ride plate a bunch, lots of small particles of oil came out. Hooked it all back up and it’s still over heating.

    thinking of trying open loop.

  8. #8
    cyrillefrenchy's Avatar
    Join Date
    Dec 2007
    Location
    st pete beach florida
    Posts
    440
    +1
    28
    it takes several flush with straight then diluted purple power or grease lightning to get rid of oil in engine cooling system, every flush should be done with engine running till hot like 180+ degrees to make sure the thermostat is open before you drain system by ride plate plug, blow air thru system to blow out dirty oily water as much as possible , then straight water. when you make sure there is no more oil in coolant then you can flush again and fill up with coolant.

  9. #9
    I flushed like a MoFo today. Still over heating. Pulled off the whole thermostat cover, discovered one of the oil radiator lines too be blocked by oil.

  10. #10
    Quote Originally Posted by andrew1289 View Post
    Actually seadoo calls it a radiator. But thatís not important. Also I said the exhaust was cool. About 100 f.

    i connected the ski to budds, I was getting 217f at engine coolant sensor.

    i tryed flushing the ride plate a bunch, lots of small particles of oil came out. Hooked it all back up and itís still over heating.

    thinking of trying open loop.
    Lol oil radiator is a French mans interpretation of English.
    My bad I missed the ďnotĒ overheating part about the manifold when I read it first.

  11. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Let's Get Into it - Oil in Coolant
    By Shibby1485 in forum 4-Tec Performance
    Replies: 32
    Last Post: 10-04-2016, 05:27 PM
  2. Oil in coolant...Need some input
    By RustySeaRustyDoo in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-04-2015, 05:01 AM
  3. 4 tec oil in coolant
    By hustler21 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-24-2010, 08:08 PM
  4. oil in coolant
    By Offshore Animal in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-22-2009, 06:19 PM
  5. gti 4 tec oil in coolant
    By faster7581 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-07-2008, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •