Results 1 to 10 of 10
  1. #1
    gprxpduglas's Avatar
    Join Date
    Sep 2014
    Location
    ONTARIO
    Posts
    610
    +1
    21

    dropping rmps 2016 rxpx rev at 8800 stock charger. has all on to rev 9200.

    I have a rxpx 300 reving 8800rpms but when my gas is a little.old like 3 to 4weeks and it is like one to 2 bars on it when i go full open start dropping rpms... like it starts good to 8800 or 8700 then start acting and dropping rmps to 6900 or 7200 and if i kept going still dropping and comes back back with power again. why u think
    ...... because not enogh gas?, fuel... it is tune by Jesus Garcia


  2. #2
    Banned User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    348
    +1
    22
    It may be your fuel pump going. Its also a good idea to add fuel stabilizer at every fill up.

  3. #3
    gprxpduglas's Avatar
    Join Date
    Sep 2014
    Location
    ONTARIO
    Posts
    610
    +1
    21
    it only does it when its one bar maybe 2 bars...in fuel.
    I put 20 liters and not issues at all

  4. #4
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,456
    +1
    283
    Quote Originally Posted by gprxpduglas View Post
    it only does it when its one bar maybe 2 bars...in fuel.
    I put 20 liters and not issues at all
    So it happens after 2 hrs of riding, there abouts?
    What happens if you dont let it get that low, and top up. Will it still do it? I guess what I'm getting at is it a run time issue and then this occurs or various run times just fuel level?

  5. #5
    gprxpduglas's Avatar
    Join Date
    Sep 2014
    Location
    ONTARIO
    Posts
    610
    +1
    21
    Quote Originally Posted by moparguy View Post
    So it happens after 2 hrs of riding, there abouts?
    What happens if you dont let it get that low, and top up. Will it still do it? I guess what I'm getting at is it a run time issue and then this occurs or various run times just fuel level?

    it does happens when the gas is low as mentioned,and u right it is just fuel. I tested it a lot yesterday. I thought was the fuel pump but it is not. it just not enogh fuel.

  6. #6
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,456
    +1
    283
    Quote Originally Posted by gprxpduglas View Post
    it does happens when the gas is low as mentioned,and u right it is just fuel. I tested it a lot yesterday. I thought was the fuel pump but it is not. it just not enogh fuel.
    Have you checked fuel pump pickup in tank, and made sure nothing clogging it?

  7. #7
    gprxpduglas's Avatar
    Join Date
    Sep 2014
    Location
    ONTARIO
    Posts
    610
    +1
    21
    Quote Originally Posted by moparguy View Post
    Have you checked fuel pump pickup in tank, and made sure nothing clogging it?

    no, i havent. as I believe that it will be clogging even if i put 3 bars of gas. but good point.

  8. #8
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,456
    +1
    283
    Could be some sediment, that at 2 bars the pickup catches and at 3 bars doesnt.

  9. #9
    Banned User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    348
    +1
    22
    Always keep the fuel tank topped up with fuel. Add fuel after each use to keep it topped up. Don't bring the fuel level low and add little fuel at each use.. I always add STA-BIL 22264 360 Performance with Vapor Technology at every fill up.

  10. #10
    ou812's Avatar
    Join Date
    Jun 2006
    Location
    Riverside,ca
    Posts
    6,254
    +1
    206
    Does it stumble if you nail it from idle when low on gas? Could just be the fuel and G force fighting each other with the Fuel pickup...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2016 RXPX-300 Stock prop vs Solas 13/18 Prop RPM difference
    By MotleyDrew in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-14-2018, 04:28 PM
  2. HELP-rxpx Rev limited to 7680 at 14 hours
    By Aric in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 07-31-2016, 06:58 PM
  3. Vtech Tune banging rev limiter at 8800 rpm on take off
    By suicidebonger in forum Sea Doo Spark
    Replies: 8
    Last Post: 07-13-2014, 08:59 PM
  4. rxpx problem at 3 hours
    By nobbyq in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-16-2008, 05:26 PM
  5. RPMs at 8250 Stock
    By meeper in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-14-2006, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •