Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: kinda bummed

  1. #1

    kinda bummed

    Been chasing what I thought was a dirty fuel/clogged injector problem for the past coupla/3-4 weeks. I went out today with another clean+(er) tank of fuel and had the same prob continue.... dead spot on the jump....surging....between 5500-6500rpm or so. When I finally got up top...ran just fine....(at the time I thought so).....still down 3-4mph.....maybe 100-200rpm. After a coupla mile at WOT I eased on down to idle...then hit it hard. No hesitation...all the way to 7950 or so. Still down speed though. Repeated those a few times, same result...no probs. At the bridge I pulled into a no wake zone fore maybe a 10min round trip...came back out and hit it again. Same as when I started out. Hesitation...dead spot at 5500 or so till I got on top then fine.

    Now...I'd been thinking dirty fuel...clogged injectors...but one thing didn't add up to that......reduction of symptoms and seeming increased performance up top. Seems to me....dirty injectors don't clean themselves because of a greater demand...seemed to me...the increased demand would exacerbate the prob...maybe not...but that's what I figure.

    I kept thinking the motor was being choked....something....was...is holding it back. When it finally does over come...it ain't all there.

    After I got it home I exposed the motor. Tank wasn't caved in so a lil vent prob got solved(I hope). I pulled the intake...dirty....wiped it out with Break Clean. Then finally did what should been done weeks ago.....pulled the IC.

    Water poured outa both hoses...and one of the core openings. Not alot....but it was there. My heart sank. I blew on the water inlet nipple and capped the exit hose with my thumb....and heard air inside the IC.

    FVCK!


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,445
    +1
    143
    Don't be bummed, you found the problem! I assume you mean the stock IC, Perfect reason to get a Fizzle!

  3. #3
    Sorry to say....it is a Fizzle.

  4. #4
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    4,172
    +1
    180
    Quote Originally Posted by VaRedneck View Post
    Sorry to say....it is a Fizzle.
    they don’t last forever. Even the good ones.

  5. #5
    I know...only a coupla yrs old....wasn't blaming anyone.

    Just wanted to get the symptoms and what I believe to be the cause out there for the next guy, is all.

  6. #6
    Banned User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    348
    +1
    22
    Could have been worst if it hydrolocked. Good thing you found it. I've installed several fizzle XS intercoolers. None have failed as I recommend replacing them every 4-5 years, cheap insurance at $150 a pop..

  7. #7
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,771
    +1
    887
    Please send it to me for a pressure test if you don't mind, and I will cover part of the costs if it turns out that you need a replacement. Remind me your email address so I can send a shipping label to you. Thanks!

  8. +1 by:


  9. #8
    Quote Originally Posted by jackywacky067 View Post
    Could have been worst if it hydrolocked. Good thing you found it. I've installed several fizzle XS intercoolers. None have failed as I recommend replacing them every 4-5 years, cheap insurance at $150 a pop..
    Re hydro-locking...agreed. I figure the dead spot on the jump was the puddle collected from a slow drip without the full blast of charged air to push it into the motor.

    Not sure why the stumbling/surging higher up...except maybe has to do when the charger finally starts making boost? Then even higher...must notta been putting out enough water to affect the combustion...too bad.

    Where are you getting XS IC's for a buck fifty?

  10. +1 by:


  11. #9
    Quote Originally Posted by JFizzleJR View Post
    Please send it to me for a pressure test if you don't mind, and I will cover part of the costs if it turns out that you need a replacement. Remind me your email address so I can send a shipping label to you. Thanks!
    You sure, James? I'm not blaming you or nuthin like that.

  12. #10
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,771
    +1
    887
    Quote Originally Posted by VaRedneck View Post
    You sure, James? I'm not blaming you or nuthin like that.
    I appreciate that, but I want to help. I always try to help if something ever happens. Whether it's a year old, 8 years old, taken care of or abused or anything in between, it's still my product and I take pride in that


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kinda bummed
    By Mike H in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 07-23-2015, 09:37 AM
  2. 65.7 Kinda Bummed!
    By meirvin in forum 4-Tec Performance
    Replies: 31
    Last Post: 07-31-2007, 05:55 AM
  3. What kinda vest to get??
    By TroyRXP15 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 01-13-2006, 03:40 PM
  4. What kinda rate did you guys get on your skis.
    By beachboy66 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 01-13-2006, 12:14 AM
  5. engine kinda died on me
    By jungo in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-04-2005, 11:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •