Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    outnumbered's Avatar
    Join Date
    May 2007
    Location
    Locust NC
    Posts
    601
    +1
    98

    Installing a pump wedge

    This is probably a stupid question, but should I reseal the pump nozzle before putting everything back together?


  2. #2
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,711
    +1
    110
    Yes you should...

  3. #3
    outnumbered's Avatar
    Join Date
    May 2007
    Location
    Locust NC
    Posts
    601
    +1
    98
    Thanks.....and thanks for all your other advice as well. It is greatly appreciated.

  4. #4
    outnumbered's Avatar
    Join Date
    May 2007
    Location
    Locust NC
    Posts
    601
    +1
    98
    Will RTV silicone work, or does it need to be something different?

  5. #5
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,711
    +1
    110
    That should be fine..

  6. #6
    Ktmman's Avatar
    Join Date
    Apr 2017
    Location
    Australia
    Posts
    461
    +1
    30
    Wat pump wedge did u try? R&d or dt ?

  7. #7
    outnumbered's Avatar
    Join Date
    May 2007
    Location
    Locust NC
    Posts
    601
    +1
    98
    Quote Originally Posted by Ktmman View Post
    Wat pump wedge did u try? R&d or dt ?
    Dean's Team. I was told that R&D didn't actually make a wedge. I got mine through the site store.

  8. #8
    Ktmman's Avatar
    Join Date
    Apr 2017
    Location
    Australia
    Posts
    461
    +1
    30
    Quote Originally Posted by outnumbered View Post
    Dean's Team. I was told that R&D didn't actually make a wedge. I got mine through the site store.
    Wow. Though mine was r&d, must be another brand then

  9. #9
    outnumbered's Avatar
    Join Date
    May 2007
    Location
    Locust NC
    Posts
    601
    +1
    98
    Got it installed, and went to the lake this morning. I'm trying to make a fair comparison, so here were the results when I hit 86.1 a couple of months ago.

    2 bars of gas
    cold motor
    It was hot, but the humidity was much lower


    Today with the wedge

    2 bars of gas
    Completely heat soaked motor
    Dew point 71 and humidity 97%
    84.2

    Is the opinion that the hot motor and extremely high humidity would have dropped my top speed? I just don't think the wedge would have dropped me by almost 2 mph.

  10. #10
    Ktmman's Avatar
    Join Date
    Apr 2017
    Location
    Australia
    Posts
    461
    +1
    30
    Quote Originally Posted by outnumbered View Post
    Got it installed, and went to the lake this morning. I'm trying to make a fair comparison, so here were the results when I hit 86.1 a couple of months ago.

    2 bars of gas
    cold motor
    It was hot, but the humidity was much lower


    Today with the wedge

    2 bars of gas
    Completely heat soaked motor
    Dew point 71 and humidity 97%
    84.2

    Is the opinion that the hot motor and extremely high humidity would have dropped my top speed? I just don't think the wedge would have dropped me by almost 2 mph.
    Probably from heat...
    Try different trim settings... with me all way to top it wasn’t quicker... one trim down worked for me

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pump wedge install
    By mattydipps in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-20-2013, 05:52 AM
  2. pump wedge install
    By bigbubba1989 in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-25-2009, 04:43 PM
  3. Steering problem after pump wedge installation
    By Mike 15Fer in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-31-2008, 07:51 AM
  4. Pump Wedge Install Question
    By BLACKSTI in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-28-2007, 05:30 PM
  5. Ultra 250 Installation of Pump Wedge
    By Skips313 in forum Kawasaki Tech Tips and Info
    Replies: 0
    Last Post: 07-06-2007, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •