Page 3 of 3 FirstFirst 1 2 3
Results 21 to 26 of 26
  1. #21

    Join Date
    Jul 2007
    Location
    Oshawa Ontario Canada
    Posts
    79
    +1
    1
    Got all the gas out safely. Started rough but ran well after a few minutes. I will get into the carbs when I get time, probably in a couple weeks. Thanks to all for your help, suggestions, and advice.

  2. #22

    Join Date
    Jul 2007
    Location
    Oshawa Ontario Canada
    Posts
    79
    +1
    1
    One more question guys...since the ski ran well after I got all the gas removed can I assume that the leak into the crankcase was not via the fuel pump diaphragm but rather through one of the carburetor's needle/seat??..

  3. #23

    Join Date
    Jul 2007
    Location
    Oshawa Ontario Canada
    Posts
    79
    +1
    1
    Quote Originally Posted by Mockingee View Post
    I would think if you take the plug out of the flywheel cover and turn the engine a bit you should be able to tell if there's fuel in there. If there's only a bit I would think the flywheel would be wet on the bottom.

    No gas in the flywheel/Stator...Yes!

  4. #24
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    3,232
    +1
    176
    Probably a bad needle tip, maybe a faulty gas tank vent not relieving pressure too.

  5. #25

    Join Date
    Jul 2007
    Location
    Oshawa Ontario Canada
    Posts
    79
    +1
    1
    Carbs are coming off next week to rebuild, will check the popoff then.


  6. #26

    Join Date
    Jul 2007
    Location
    Oshawa Ontario Canada
    Posts
    79
    +1
    1
    Quote Originally Posted by Myself View Post
    Probably a bad needle tip, maybe a faulty gas tank vent not relieving pressure too.

    I checked for a large "swoosh" of air last time I opened the fuel cap, it was no more than the usual "pffft" sound...

Page 3 of 3 FirstFirst 1 2 3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stx1100 di engine full of water
    By fzrchad in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 09-27-2011, 02:39 PM
  2. 1996 SLT 780 engine won't turn over
    By kabadou in forum Polaris Open Discussion
    Replies: 19
    Last Post: 04-22-2011, 08:43 AM
  3. 94 SL750 cylinders full of gas now battery goes dead!!!!
    By kellyoc in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-26-2009, 01:01 AM
  4. 96 polarios slt 780 engine mod
    By polaris96 in forum Polaris PWC Performance
    Replies: 6
    Last Post: 03-24-2009, 10:32 PM
  5. 1999 GP1200 Engine Full of Water
    By anieve in forum Yamaha Open Discussion
    Replies: 15
    Last Post: 08-31-2008, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •