Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2015
    Location
    Oklahoma
    Posts
    13

    2007 GTI SE 130 reliability question

    Hi all!

    I'm a new Sea Doo owner and recently purchased a 2007 GTI SE 130 that has 79 hours on it. It performs great and has no issues but I recently ran across some threads about timing chains breaking on the 4-tec engines of that year. I spoke with the mechanic at my Sea Doo shop and he said since it isn't on a recall list that there is no need to worry about it and that the engine will last a long time. Should I be concerned? Has anyone replaced their timing chain proactively for this issue?

    I appreciate any help on this!

    Danny


  2. #2
    bill321's Avatar
    Join Date
    Oct 2012
    Location
    Lady Lake, Fl
    Posts
    327
    +1
    54
    I never heard of this on this model,I wouldn't worry about it and definitely not change it. Modded SC skis may have failures at times but I seriously doubt a stock GTI 130 would.

  3. #3

    Join Date
    Aug 2015
    Location
    Oklahoma
    Posts
    13
    Bill, thanks for the response. The reason I looked into this was because I considered buying another 2007 GTI SE 130 with 50 hours on it that was throwing a p0344 code (camshaft position sensor error). When I did some research, I found some threads about timing chains breaking on 2007 models but they were mostly on the SC models. I did a compression check on the 2007 GTI SE 130 that was throwing the code and it had less than 30 psi on all three cylinders so I assumed it had a broken chain. But it sounds like this is a very uncommon problem on the non SC models. Many thanks for your help. I'm not going to worry about mine!

    Danny

  4. #4
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    300
    +1
    22
    Danny, Less than 30 PSI on all 3 cylinders is unheard of. I would say that the other one you looked at already had a broken timing chain. I can't think of any other cause of compression that low.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [help] 2007 GTI SE 130- no power to fuel pump
    By Sik_z33 in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-10-2018, 03:02 PM
  2. 2007 Sea Doo GTI SE 130 PTO removal kicking my butt
    By Kel in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-01-2017, 10:05 PM
  3. 2007 GTI SE 130 Idling RPM
    By Shacho762 in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-08-2015, 08:17 PM
  4. Shop manual 2007 GTI SE 155??
    By lefty08 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-07-2007, 04:55 PM
  5. 2007 GTi SE 155???
    By Waterlogged in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-26-2007, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •